LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

SCC fails in check-in of file. Won't allow file to be checked back into SCC.

I have edited a file in Labview. I checked it out of our SCC source directory, edited it and then went to check it back in but it says that check in failed:
 
"Error 7 occurred at Invoke Node in Version Control CIN.vi->SCC Enter Change Comments.vi->Builtin SCC Checkin.vi->Builtin SCC Checkin GUI.vi->Check In.vi""
 
I don't know how to proceed - I"ve tried undoing the check out, then re-checking the file out and making the changes and it still fails on check in. this file is used in multiple projects, and I need to ensure that it is available to other users when they use those projects.
 
Chris
 
0 Kudos
Message 1 of 8
(1,176 Views)
These kinds of problems are tricky since there are many variables. Does this problem only occur on one specific file or for all files (i.e. you can't check in anything)? Does this happen on another machine or is it specific to your machine? What version on LabVIEW are you using?  You could try opening this file "<LabVIEW dirctory>\project\Source Code Control\_sccsbvi\SCC Enter Change Comments.vi" and seeing what filename is being used. That particular VI checks for the file's revision history. If that file has never been checked in, that could be another reason for the error.
George M
National Instruments
0 Kudos
Message 2 of 8
(1,164 Views)
Hi gmart,
 
Thanks for your reply.
 
I checked the SCC Enter Change Comments.vi, and the filename is correct. When I attempt a check-in the error message of this VI is:
 
"Invoke Node in Version Control CIN.vi->SCC Enter Change Comments.vi->Builtin SCC Checkin.vi->Builtin SCC Checkin GUI.vi-"
 
I am using Labview 7.1. I can check out and in other files, but I can't check-in this particular file on any machine. (If i check it out and then attempt to check it in anywhere I get the same error.)
 
The possible reasons it lists for failing are:
 
Possible reason(s):
LabVIEW:  File not found. The file might have been moved or deleted, or the file path might be incorrectly formatted for the operating system. For example, use \ as path separators on Windows, : on Mac OS, and / on UNIX.
---
NI-488:  Non-existent board.
 
The file is definitely there, and the path looks fine.
 
Chris
0 Kudos
Message 3 of 8
(1,155 Views)
Thank you for the information. Glad we could narrow down the problem. If the path going into the VI I mentioned looks correct (what is the path that is in the path control of the "SCC Enter Change Comments" VI?), then the issue seems to be with LabVIEW's attempt to get history from a specified date. Unfortunately, it is very difficult to debug these types of problems remotely since your system is unique from others. If you feel comfortable, you could debug the calling VI (<LabVIEW>\project\Source Code Control\_backend\Builtin\Builtin SCC Checkin.vi) to see what data the VI is passing around. I apologize I can't be more helpful.
George M
National Instruments
0 Kudos
Message 4 of 8
(1,152 Views)

Hi,

The path in the control is: C:\Documents and Settings\projects\Labview\eye diagram\eye_diagram_v4.vi

The dates in that are being passed around seem okay, but it's hard to tell. In the SCC Checkin chk dates.vi, the last mod date is: 04:57:13 PM
05/21/2004 which doesn't seem right to me, but it's hard for me to find out if that was the last time the vi was modified. It very well could be. The checkout date is correct.

The dates in the Version Control CIN.vi are all: 08:00:00 PM 12/31/1903.

The version control CIN.vi is password locked so I can't see how those dates are being determined.

Thanks for your help!

Chris

 

0 Kudos
Message 5 of 8
(1,148 Views)

I have version 7.1 of LabVIEW. I have found I can't have revision history and use the builtin SCC. Does National Instruments have a fix for this, or do I need to go to another version source control program, like SourceSafe?

Message Edited by LV_J on 12-18-2006 06:48 PM

0 Kudos
Message 6 of 8
(1,065 Views)
LV_J,

So if you add comments to the revision history you can't use the Check In functionality, is that correct?  This is a known issue and was corrected for LabVIEW 8.  As you probably are aware clearing the revision history will stop this error that you are recieving. 

If you are interested in testing it out, we are currently on LabVIEW version 8.2.  Here is a link to the evaluation version.  Please let me know if you have any other problems!

Thanks!
Andy F.
-----------------------------------------------------------------
National Instruments
0 Kudos
Message 7 of 8
(1,047 Views)
Highlighted

Hi Andy,

That is correct. I just didn't find any info that NI stated this was a bug, just solutions to reset rev history. My company hasn't allowed me to upgrade to Version 8 yet.

Jay

0 Kudos
Message 8 of 8
(1,043 Views)