LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

SCADA Sample Project doesn't transmit alarms

Solved!
Go to solution

Hello,

 

I was trying out the new SCADA Sample Project that came with LabVIEW + DSC 2013: File -> Create Project... -> Sample Projects -> Supervisory Control and Data Acquisition System. I deployed the libraries and then ran Client Main.vi and Server Main.vi.

 

If the Client and Server are running on the same PC, everything seems to work fine. The Client receives value updates, and the controls start blinking red if an alarm occurs. However, if the Client and Server are on different PCs (on the same LAN), then the Client only receives value updates from the Server -- it does not receive any alarms, even though the firewall has been disabled on both PCs.

 

How do I get the Client to receive alarms when it's on a different PC in this case?

 

Thanks!

Certified LabVIEW Developer

0 Kudos
Message 1 of 16
(1,780 Views)

Are you trying to enable logging on two different computers? (Your Project -> Right Click on the Library -> Properties -> DSC Settings: Database)

David H.
National Instruments
0 Kudos
Message 2 of 16
(1,744 Views)

Hi David,

 

No I didn't try to enable logging at all, or change any settings other than the IP address (to tell the Client where to find the Server).

 

I simply:

  1. Created a new project based on the "SCADA Sample Project" template
  2. Deployed the libraries under "IO Simulation" as-is
  3. Ran Server Main.vi
  4. Ran Client Main.vi
  5. Ran cRIO IO Simulation.vi (to generate data).

 

If the Client VI is on the same PC as the Server VI, the Client gets alarm events immediately in Step #4. If they're on different PCs, the Client doesn't get alarm events.

Certified LabVIEW Developer

0 Kudos
Message 3 of 16
(1,693 Views)

Have you tried having the Client on a PC other than the one that is not currently receiving alarms? 

David H.
National Instruments
0 Kudos
Message 4 of 16
(1,669 Views)

Hi David,

 

Sorry for the delay.

 

Yes we tried this with different combinations of 3 PCs in our office. Each PC took turns being a Server and a Client.

 

The result was the same, no matter what pairing we had.

 

Could it be a network settings issue? Is there a way to detect if a connection is refused? (Note that normal data is transmitted fine; it's only alarms that don't seem to get transmitted)

Certified LabVIEW Developer

0 Kudos
Message 5 of 16
(1,586 Views)

What are you running on each computer? DSC or DSC Run-Time (DSC RTS)?

 

I'm thinking you may just have shared variable functionality but not the alarming functionality that comes with DSC on the client side.

David H.
National Instruments
0 Kudos
Message 6 of 16
(1,563 Views)

Have you configure Client.ini for the "ServerComputer"? Did you use computer name or IP address?

0 Kudos
Message 7 of 16
(1,438 Views)

@David-H wrote:

What are you running on each computer? DSC or DSC Run-Time (DSC RTS)?

 

I'm thinking you may just have shared variable functionality but not the alarming functionality that comes with DSC on the client side.


All computers have the development version of DSC, installed from the NI Developer Suite. All computers have alarming support.

 


@YanYuan wrote:

Have you configure Client.ini for the "ServerComputer"? Did you use computer name or IP address?


Yes, I modified "ServerComputer" in Client.ini to switch between local and remote servers.

 

  • If I use a local server (ServerComputer="localhost"), my Client receives data and alarms.
  • If I use a remote server (ServerComputer="192.168.1.99"), my Client receives data only, but it doesn't receive alarms.

 

Have you tried running this project on multiple computers? Does it work correctly for you?

Certified LabVIEW Developer

0 Kudos
Message 8 of 16
(1,432 Views)
Solution
Accepted by topic author JKSH

Yes, it works correctly for me on multiple computer. Can you try to use the Computer Name in the Client.ini file for the server computer instead of the IP address (192.168.1.99 in your case)?

Message 9 of 16
(1,428 Views)

@YanYuan wrote:

Yes, it works correctly for me on multiple computer. Can you try to use the Computer Name in the Client.ini file for the server computer instead of the IP address (192.168.1.99 in your case)?


Interesting! When I typed in the PC name instead of IP address, it worked!

 

Is this expected? Why don't alarms work when I use an IP address?

Certified LabVIEW Developer

0 Kudos
Message 10 of 16
(1,420 Views)