LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Running Labview 8.6 vi will not run in 2010

Highlighted

I am trying to run a VI that has worked in Labview 8.6 and trying start or run in 2010

will not function and stops 2010 from working and removes all from memory

 

The llb loads ok but when the main vi is started it stalls for a few seconds then 2010 quits

 

This llb in 8.6 works fine as it has for over a year

The llb can be saved to 2010 in a file and called again

but still will not run

 

all the vi's in the llb run separately and are saved in 2010 to a new dir

but the llb will not start

 

What is missing here

0 Kudos
Message 1 of 9
(1,018 Views)
Highlighted
Did someone do something silly such as saving functions from vi.lib into the llb?

Quite frankly, if you can extract the VIs into a folder and it runs, leave it that way. An llb has been obsolete for several years and serves no useful purpose anymore.
0 Kudos
Message 2 of 9
(1,011 Views)
Highlighted

@kgeisler wrote:

 

What is missing here


Information. As in what your VI is doing. All you've said is that you have a VI that runs in 8.6 but not in 2010. That tells us nothing, since 2010 can load and run old code just fine in the vast majority of cases. Exceptions are usually due to deprecated functions or changed functions, or drivers that were being used that do not support 2010.

 

How To Ask Questions The Smart Way

0 Kudos
Message 3 of 9
(1,010 Views)
Highlighted

Please see section

How To Answer Questions in a Helpful Way

0 Kudos
Message 4 of 9
(988 Views)
Highlighted

The main vi will not run in 2010

it works in 8.6

 

file in a dir or not

llb or project or exe

0 Kudos
Message 5 of 9
(985 Views)
Highlighted

That kind of response is not going to help you get any answers from the forum.

 

What kind of help do you expect to get when you post a question that has no meaningful information in it?  All you say is something will not start.  What is it doing instead?  Do you get error messages?  What do the VI's do?  Is there anything special going on like toolkits or add-ons that you may not have installed with 2010.

 

If you want meaningful help, then you need to post meaningful questions with useful information and that link was S-mercurio's way to guide you how to ask a question.

0 Kudos
Message 6 of 9
(981 Views)
Highlighted

A list of vi are saved in a llb on a share drive that development people call every day

There are thousands of program that are structured in this way with a number of individuals working with them

there is no way they can be brought up to a current level

they just run good and give data for sites all over the world

Most programs were developed in 8.2, 8.6 and some new now in 2009

 

I said 2010 as this the latest before we go to 2011

This vi will also not run in 2009

 Driver There are a few which the vi never gets to that part

it just will not start in 2009 or 2010

0 Kudos
Message 7 of 9
(979 Views)
Highlighted

Let ME guess,

(because the OP will not provide details)

 

So you are working with the configuration file palatte functions!  the Config file palatte changed between 8.6 and 2009.  You must use one API or the other, mix and match does not work!

 

 

(~~~oh magic 8-ball, did the OP use the config file API? and mix while upgrading?~~~~) 

 

"Yes, but maybe it depends"

 

Thank you magic 8-Ball

"Should be" isn't "Is" -Jay
0 Kudos
Message 8 of 9
(971 Views)
Highlighted

Jeff Bohrer wrote:

 

(~~~oh magic 8-ball, did the OP use the config file API? and mix while upgrading?~~~~) 

 

"Yes, but maybe it depends"

 

Thank you magic 8-Ball


See if it tells you whether I'm going to be rich. Smiley Very Happy

0 Kudos
Message 9 of 9
(957 Views)