LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Run time engine with TestStand: Some subVIs from LabVIEW lib doesn't work in Run time engine, can someone help me?

Highlighted

Hello,

I have no experience with LabVIEW run time engine yet before.

Now I have created a simple Vi (version 2019 f2) and tried to run it on another PC of test platform( Run time engine 2019 f2 and TestStand 2014). But there is some problem with subVIs ( such as space constant, delimited string to 1D array and 1D array to delimited string).

When I tried to load the vi in TestStand. There comes windows looking for the three lib subVIs. If i choose the subVIs, there is a warning' Unable to load vi xxxx with LabVIEW run time eingine 19.0.The version of a subVI might not match the version of the run time engine or vi dependency might be missing'. The version should be right. Adapter was also configured. But it doesn't work.

And later I tried it with version 2014 (development module and run time engine), there is no delimited string to 1D array and 1D array to delimited string, but still space constant. When I run it in TestStand, it was the same. SubVI 'space constant' was looked for.

After deleting the space constant from my vi , it works at last. But I'm wondering why. Doesn't run time engine support these subVIs ? Or should I pack the subVIs in any way ?

And there is another problem at the end. I created some output message string for debugging. This works good in my TestStand. But in the tester PC these strings are not shown. Can anybody help me?

 

0 Kudos
Message 1 of 6
(436 Views)
Highlighted

If you want to run LabVIEW code in TestStand without having LabVIEW itself installed, you will need to build your VIs.  I prefer using Packed Project Libraries (PPLs) to do this.  You will need to put your code into a LabVIEW project library and then build the library into a PPL.  The PPL will include all dependencies needed to run the called VIs.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
0 Kudos
Message 2 of 6
(382 Views)
Highlighted

Hello Crossrulz,

thank you for quick answering. Should I copy both the PPL and LabVIEW project to the Tester PC? Can I use it in TestStand?

0 Kudos
Message 3 of 6
(372 Views)
Highlighted

You just need to copy the built PPL and the TestStand sequence that is calling VIs inside of it to your tester.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
0 Kudos
Message 4 of 6
(370 Views)
Highlighted

If I want to use the TestStand on the Tester PC to create the sequence, i just need to copy the built PPL to it. Right? I will try it. Thank you very much.

0 Kudos
Message 5 of 6
(355 Views)
Highlighted

Hello crossrulz,

I have tried to build a packed project library with my LabVIEW project. But can't open the .lvlibp file and select my vi in TestStand( insert step-> action->call Type: class number call->select the LabVIEW class file for the step->select .lvlibp file). After selection of file, it looks like in the attached picture.

For building PPL , I created firstly a library under 'My Computer' in the project, and put the main VI and subVIs in it, then 'build specification'. Is there anything wrong? Thank you for tipps.

0 Kudos
Message 6 of 6
(329 Views)