Showing results for 
Search instead for 
Did you mean: 

Reset revision history

How do i reset the revision history of all the VI's in a library without doing one at a time. THanks
0 Kudos
Message 1 of 6
In LV 7.0 use Invoke Node and the method Clear History. This method is missing in previous versions.


Using 7.1.1, 8.5.1, 8.6.1, 2009 on XP and RT
Don't forget to give Kudos to good answers and/or questions
Message 2 of 6
I tried it, but it doesn't reset the revision history. What's wrong with the attached code?

0 Kudos
Message 3 of 6
Hello Einstein,

I tried running your example and it cleared the revision history of all the VIs I tried. Is it possible that the file settings for the VI you are resetting is set to Read Only.


MAtt F
0 Kudos
Message 4 of 6
Hello Matt F,

I tried that, but that's not it. When I set the read-only flag, I get
Error 8 occurred at Invoke Node in
Possible reason(s):

LabVIEW: File permission error.

I also added the Access Rights VI and it indicates 110110110 when the VI is not read-only, but the history is still not reset. It's strange when you say it works for you...
I use LabVIEW 7.1 on Win XP Pro (I saved the VI that I posted earlier back to version 7.0). I have two partitions: one with NTFS and one with FAT32, but I don't see the expected result on neither of them. I do have administrative rights on this system.

I also tried other VIs, e.g. the 'Select Signal' that ships with LabVIEW (...\LabVIEW 7.1\examples\general\templates\Dialog (Base Package)\...), but no success here either 😞

Any ideas?

0 Kudos
Message 5 of 6
Hi Einstein,

I downloaded and ran your VI (on another VI), and it seemed to clear the history just fine. I'm running WinXPSP2 & LabVIEW 7.1. Have you tried running this on another machine around you?
Travis H.
National Instruments
0 Kudos
Message 6 of 6