LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Report Generation Tool Kit not appending to a new line

Solved!
Go to solution

Hello Everyone,

 

I am having a hard time getting my data to dump correctly into excel. I am currently using arbitrary columns and rows to test the program, and using the Report Generation Tool Kit. When I run the program and press the Boolean on the front panel, the data will dump once, but when I press the Boolean again to simulate dumping another round of data, it replaces the data that is already in the excel sheet. I have the "Append to new line?" function set to true so from my understanding it should move onto the next line of data. Attached is the VI I am currently working with.

 

Thanks,

Dan

0 Kudos
Message 1 of 7
(163 Views)

Make sure to keep your "report" object in a shift register so that any actions you do on it are maintained iteration to iteration. Also wire it straight through on the false case.

 

Capture.PNG

0 Kudos
Message 2 of 7
(116 Views)

Also, the NI-DMM Initialize subVI should NOT be in the while loop.  You don't want to initialize every iteration.  It belongs before the while loop.

0 Kudos
Message 3 of 7
(104 Views)

Hey Gregory, 

 

Thanks for the response. I created a shift register for the while loop and attached it to the report generation tool. I also moved the true statement for the "Append to new line?" function on the "append text data" to outside of the case structure so that it is "always" true same as you did. Even with these changes, the data is still not appending to a new line. I've attached a screenshot of the updated code along with the VI. I am going to keep working at it and see if I can figure out a solution. 

 

Thanks,

Dan

Download All
0 Kudos
Message 4 of 7
(84 Views)

Thanks for the tip! I should know better. 

 

Dan

0 Kudos
Message 5 of 7
(83 Views)
Solution
Accepted by topic author drogers13

Hmm, that "append text" VI seems more suited to Word / HTML reports. When I look at the block diagrams the "MS Office Parameters" is not even wired up, but maybe my install is corrupted or something.

 

Anyway, I'd try the Excel easy table instead:

Capture.PNG

0 Kudos
Message 6 of 7
(74 Views)

I looked into the same thing you did. It would seem that append to new line works only with MS office or word. I'm going to shift focus into using the easy excel. 

 

Thanks for you help!

Dan

0 Kudos
Message 7 of 7
(71 Views)