LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Remote access to database using ODBC connector

Solved!
Go to solution

Previously i tried using 32 bit labview and 64 bit connector to retrieve data from local database and it didn't work. So i installed the 32 bit ODBC connector and it solved the problem. Now, i am wondering if its the same issue .

0 Kudos
Message 11 of 12
(609 Views)

Only you can say for sure. But please apply normal logical debugging techniques.

If you use LabVIEW 32 bit you have to use the 32 bit ODBC connector (which you can't really influence, Windows will simply load the ODBC connector that matches the bitness of the application or fail to initialize the ODBC connector fatally) you are fine. Of course you have to use the according ODBC manager to configure the ODBC DSN for your application. If then you can connect to a local database from within your application (LabVIEW) your ODBC configuration is correct. The bitness of the database server should not matter, since they are completely seperate from each other and communicate through the hopefully well defined network protocol with each other.

If with the same setup (except of course the correct database server address) you can not connect anymore to a remote server, then the problem is not in your ODBC setup but somewhere in the connection between the ODBC connector and your database server. Go look there and research what your Amazon service allows and what not.

Basically when you setup an ODBC connection in the ODBC manager you have with most drivers a Test button that will test the connection, by establishing a connection to the server and trying to do some basic calls into it. As long as that test function doesn't succeed, either the server address or configuration in the ODBC configuration is wrong or the server is not reachable due to network issues like firewalls or something. Bitness shouldn't at all come into play there!

Since you say you try to use a server hosted in the Amazon cloud you will have to take it up with someone who has knowledge about the capabilities of that Amazon cloud and how to configure it to allow what you want to do, if at all possible. We can't help you from here anymore, it definitely looks like an issue with your service provider, which may require a specific configuration or may not even allow to access your server in the way you try to do.

 

Many webhosting services for instance do provide a mySQL server instance in a the virtual server environment that you hire and that can be used to drive an online store application or a WordPress driven blog or something else on the webserver in the same virtual server environment, but that mySQL server instance is COMPLETELY shielded from any access outside that virtual server instance. The only way to interact with that mySQL server is through the website inside the environment and the web based server administration tool which also runs inside that environment. And most will never allow an exception to that complete isolation since every open port is an unlocked door for hackers to try to get in and take over the whole virtual server environment and potentially gain from there more access to other resources in the whole cloud.

Rolf Kalbermatter
Averna BV
LabVIEW ArchitectLabVIEW ChampionLabVIEW Instructor
0 Kudos
Message 12 of 12
(604 Views)