Showing results for 
Search instead for 
Did you mean: 

Remote PXI says "No software installed" - MAX says there is

For some reason my PXI is telling me there is no software installed on it but when I look at the remote connection inside MAX on the host computer there are software listed as installed.  I'm not sure why and I think this may have something to do with my other problem - which is that the remote system does not recognize and populate the 'Devices and Interfaces' section in MAX with the six cards I have installed.  As a side note to that, if I boot up in Windows on the PXI controller all of the cards are visible in MAX.


I have a PXI-1042 with embedded controller PXI-8110 w/ hypervisor.  Right now it has all LV2010 "era" software installed which I would like to upgrade to 2011 but that's another storey.  I have it set to boot in LabVIEW RT only.  With a monitor plugged into the PXI controller it says (with some things cut out for brevity):


Transferring controler to user program.


Error booting hard drive boot program.


Initializing network... Static IP address assigned.

Device 1 - MAC address: xx:xx:xx:xx:xx:xx - (primary)

Device 2 - MAX address: xx:xx:xx:xx:xx:xx - disabled


System state: No software installed


When the PXI is in this state I can go onto the host computer, open up MAX, and it will show a list of software installed on this PXI system.  As mentioned before however, it does not show any of the device cards.


Any ideas why this might be?  Thanks.

0 Kudos
Message 1 of 17

The error message "Error booting hard drive boot program." really says it all.  When RT attempts to boot, it attempts to load LabVIEW Real-Time; if the real-time components are not present, it will give that error.  Even though you may have installed DAQ and other components, unless you install LabVIEW Real-Time you will get no OS.  That's like installing MS Word on a computer without having Windows installed (sounds funny, but when you're using a 3rd-party to remotely install software it's completely possible).  


Make sure LabVIEW Real-Time is installed on the system.



0 Kudos
Message 2 of 17

Well that's the thing.  When I look in MAX it shows that there are LabVIEW Real-Time components installed.  I'm working on just reinstalling everything and have it updated to 2011 because we are moving to that, but the machine has Hypervisor 1.1 on it and I wasn't able to get that updated (and I don't know how to update that particular feature).  I am out of town this week and I know that one of my co-workers is working on that so it may be fixed when I get back. 

0 Kudos
Message 3 of 17

Fair enough, keep us updated. I'm sure you have access to this, but just in case If you're starting from scratch, here is a getting started guide. 

Ben D.
Applications Engineer
National Instruments
0 Kudos
Message 4 of 17

I'm back in the office and they weren't able to make too much progress it seems like.  I was able to download Hypervisor21SharedMemory.exe and I attempted to install it to the host PC with the intent on installing it on my target.  When installing it, it asked for a serial number which another co-worker was able to get from NI.  So I put it in and installed all the 2011 support and Hypervisor 2.1 Shared Memory.  It said it was successful and I restarted the machine.  Then when I went to check to see if it was installed, there was nothing in the Start>Programs>National Instruements directory and was not shown in MAX when trying to update the target.  What would be some causes of this?

0 Kudos
Message 5 of 17

It appears you should be downloading the software directly to the PXI controller rather than the host computer.

Ben D.
Applications Engineer
National Instruments
0 Kudos
Message 6 of 17

So I logged onto the Windows side of the PXI controller and followed these instructions to install Hypervisor 2.1.


I used the following installation files.


But then realized those are just the VIs for editing it.  Is there somewhere, where I can download the installation files for Hypervisor 2.1.  I think my lack of realization what I was actually installing has lead to part of this problem.  One of my co-workers have talked to NI and they are going to send us a disk at his request but if possible I'd like to start the installation today as it is holding up development.



0 Kudos
Message 7 of 17

So I have Hypervisor 2.1 installed now.


When I boot into Hypervisor mode showed a connected between the Windows host and the RT PXI partition.  When I click on software to try to add/remove it times out.  And now it doesn't even connect to the PXI.


How do I make this connection, I seem to be having some difficulty.  I have an ethernet port in the controller and an ethernet card in the chassis.  There is also the virtual ethernet port that can be set up.  Is there some trick I am missing?  I have tried using a crossover cable between the two ethernet ports (in the Hypervisor manager one is set to Windows and one is set to Real-Time) and I also tried to enable the virtual ethernet port.  Neither seem to be working or I am missing something.


I have them all set to static IPs that are along the lines of 196.254.1.x with a subnet mask of  They all say they are connected.  Any ideas?

0 Kudos
Message 8 of 17

So this doesn't go unresolved.  I did eventually figure it out today.  Ended up being some messed up IP settings and used a crossover between the two different ethernet ports. I still couldn't get it to work with the virtual ethernet port for some reason.

0 Kudos
Message 9 of 17

Glad to hear you found a workaround and even documented it. With regards to your second question. This may sound basic, but I have to ask. Did you enable the virtual ethernet port?

Ben D.
Applications Engineer
National Instruments
0 Kudos
Message 10 of 17