LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Reading Data from CAN device

Greetings,

 

I've connected a CAN device to my PC via NI 9860 cartidge within a NI-9179 chassis. I've been able to open up the interface on MAX and view the Bus Monitor. I am receiving signals just fine.

 

To view the signals in a LabVIEW program, I've started a new project and added an XNet Session, Signal Input - Single Point. I dragged the session into my program, but it gives me the following error: "A signal/frame session has been opened, but it doesn't contained signals or frames." The bus monitor definitely did show that I am receiving signals properly, so why is LabVIEW telling me I'm not?

 

I've tried Signal Input - Waveform and XY and neither work. I've also tried Frame Input - Single Point, Waveform, and XY and none worked.

 

This is the link I used to create an XNET session. Please note, I just want to be able to read RAW DATA from my CAN device, there is no need to go any further, such as adding databases or other useless things.

http://www.ni.com/product-documentation/12375/en/

 

Can someone help me?

 

Cheers,

Momo

0 Kudos
Message 1 of 3
(1,399 Views)

I would start by looking in the example finder. There should be a folder for hardware with an XNET folder under that. I think you are looking for the frame stream example but let me know if that's not it and I'll look again when I have LabVIEW in front of me.

Matt J | National Instruments | CLA

GCentral
0 Kudos
Message 2 of 3
(1,342 Views)

Hi Momo,

it seems to me that you have not added signals / frames to the database. you should have a block that does that...or you can do it manually in the property editor but i cannot remember where that is...

0 Kudos
Message 3 of 3
(1,305 Views)