LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Read from Spreadsheet File appends blank line

I have an issue with the read from spreadsheet file. My program uses an automatically generated spreadsheet file that is output by our business control software. Recently this software was upgraded and since then the file will not correctly import into LabVIEW. The three issues I am seeing with this new file are:

1.) The beginning of the file has an extraneous set of characters (hex FEE). I can easily remove them so that isn't a problem.

2.) After each row of data an empty row is entered, doubling the size of the array of data.

3.) The characters in each entry are separated by a space, though they should be a single string.

 

oldvsnew.JPG

 

Does anyone have any suggestions as to why this is happening, or what I can do to correct this? I am assuming that the encoding is different on the files, but I am not sure what I can do to work around that. At first I thought it was a result of upgrading LabVIEW from 2011 to 2012, but both give the same results.

 

I have attached the old and new file, if that helps.

 

Thanks!

0 Kudos
Message 1 of 2
(744 Views)

The prefix you see in the file indicates it has been written in unicode format.

 

You could ask the provider of the data file to store it in straight ascii, or adapt your LabVIEW code to read the file.

 

See this for info on working with unicode files in LabVIEW.

 

https://decibel.ni.com/content/docs/DOC-10153

 

 

 


Now is the right time to use %^<%Y-%m-%dT%H:%M:%S%3uZ>T
If you don't hate time zones, you're not a real programmer.

"You are what you don't automate"
Inplaceness is synonymous with insidiousness

Message 2 of 2
(728 Views)