Showing results for 
Search instead for 
Did you mean: 

Read-Write VISA Stopping Response issue

Go to solution

@Tusharvp4 wrote:

Yes..My serial protocol is binary..


But you have a property node that is set to send the termination character on every write.  So you are actually sending the 4 bytes plus a line feed character.  That seems contradictory to not looking for a termination character when doing the VISA Read.


How can I can solve contradiction of a terminal character at VISA READ...??


I went to many thread , but I was enable to find solution...

Just get rid of that case structure with a True constant wired to it that forces the termination character on every serial write.  The Serial Configure has properly handled disabling the termination characters for reads.  (Assuming the protocol works the way you say it does.)

0 Kudos
Message 11 of 14

Here...I tried with state machine design...Still having same issue...(Tried many terminal characters disable and enable, Did not get success)..



0 Kudos
Message 12 of 14
Accepted by Tusharvp4

You need to get rid of the Feedback Node in the VI where you are reading the data.  You are just processing old data because of that.

There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
Message 13 of 14

Thank you..Its working now

0 Kudos
Message 14 of 14