LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Read 2182A by triggering through 6221

0 Kudos
Message 41 of 48
(476 Views)

Hi Eyuzuak,

 

In order to use the Instrument I/O assistant you need to have NI VISA and NI 488.2 intalled. 

The link below provides additional information on the procedure to follow if you are not able to access the Instruments I/O Assistant.

http://digital.ni.com/public.nsf/allkb/DC808866AF7D5C0986256FCE006E9BAB

 

Regards

Carli S.
Troubleshooting & Maintenance Digital Business Manager - National Instruments
0 Kudos
Message 42 of 48
(471 Views)

 

Have you got any *.vi program or trees for using

 

2182A by triggering through 6221.

 

Thanks.

0 Kudos
Message 43 of 48
(456 Views)

Hi,

I am communicating with a 6221 from my PC via Ethernet  cable and I have a 2182 Nanovoltmeter connected via RS-232 and trigger link cable to 6221.

But I am not getting any data when I send command.

I also used drivers fro keithley. I am able to set current on 6221 using these drivers but not able to read voltage on nanovoltmeter.

 

Thanks for any support.

Rupali

0 Kudos
Message 44 of 48
(282 Views)

I am having some trouble connecting a 2182A nanovoltmeter to a 6221 current source using the pc control system. The current source connection with the ethernet works fine, but the nanovoltmeter encounters a -113 error (Unidentified Header). The RS-232 and the trigger link cable are connected as indicated and the RS-232 is on. I can't find what's the problem.

Following settings on  Model 2182A are done

for RS-232 with
19,2k BAUD
FLOW = NONE
TC TERM = CR

 

Any example vi is more helpful for me.

Thanks.

Rupali

0 Kudos
Message 45 of 48
(272 Views)

Since you are using third party instruments and third party drivers, the best place to look for a shipping example is with Keithley. You may also try opening a new forum post to get more attention from the community. Thanks!

0 Kudos
Message 46 of 48
(255 Views)

I have the same problem too , error -222 parameter out of range. I can not control my source using KI6220.vi. Anybody help ?

0 Kudos
Message 47 of 48
(110 Views)

Hey Oulll,

 

This thread is from 2008 and likely will not be actively viewed! I would recommend making a new forum post with your issue to get better visibility.

 

--Hunter

Hunter D.
Applications Engineer
0 Kudos
Message 48 of 48
(94 Views)