LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

RT target is running at 99.8% CPU


Hillman wrote:

Hi Ben,

 

I was indeed confirming - as you seemed a little unsure when I read the post yesterday. 

 

I was wondering if the question concerning the cRIO had be resolved?


Thanks James!

 

I was wondering the same thing and have an emoticon for just this occation.

 

 

 

Ben

 

PS Solved icon can befound here or if you want to find it just enter the search phrase "Solved icon".

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
Message 11 of 18
(1,273 Views)

Hi,

 

I ran my test on a cRIO-9014, both in scan mode and with the FPGA interface, so I don't think you should see this behavior on the cRIO.

 

What happens if you slow the loop down from 40 ms to say, 500 ms?  The timed loop has some statistics on the input node if you expand it out, you can use that to see if it is missing deadlines.  You have a fair amount of signal processing, I'm wondering if that is just maxing it out.
Regards,

Jeremy_B

Applications Engineer
National Instruments
0 Kudos
Message 12 of 18
(1,253 Views)

Hi

Thanks for the reply.

I checked CRIO cpu usage using distributed systems manager. There is also real time systems manager to check cpu usage of RT controller. I couldn't get this to see any info about cpu. In distributed systems manager I was able see cpu usage. Do these system show same information?

 

I slowed the loop rate and still showing 99% cpu usage. Thanks very much for your help

 

 

0 Kudos
Message 13 of 18
(1,241 Views)

Hi,

 

In the real time system manager, you have to enable CPU usage tracking, there is a checkbox for it.

 

Put an indicator on the finished late indicator on the timed loop and see if it is meeting its timing.

Regards,

Jeremy_B

Applications Engineer
National Instruments
0 Kudos
Message 14 of 18
(1,223 Views)
I enable CPU usage tracking still didn't show anything. I have tcp port selected as 3363. Does that need to be changed? Thanks.
0 Kudos
Message 15 of 18
(1,209 Views)

Do you have VI server enabled on the 9014?

 

 

Regards,

Jeremy_B

Applications Engineer
National Instruments
0 Kudos
Message 16 of 18
(1,195 Views)

i did select tcp in vi server configuration page in RT tartget.

0 Kudos
Message 17 of 18
(1,177 Views)

Hi Suni,

 

Are you programming CompactRIO in scan mode?

 

If so, what do you have the scan period set to? Here is a table from the NI Scan Engine benchmarks page: http://zone.ni.com/devzone/cda/tut/p/id/7792

 

 

Number of Channels

(AI/AO pair)

100 Hz

500 Hz

1000 Hz

1

10.29%

31.53%

54.71%

16

15.5%

47.41%

94.96%

32

17.98%

66.58%

n/a

64

26.62%

96.22%

n/a

80

28.61%

n/a

n/a

 

As you can see from the chart, if you have a high channel count and are running the scan period at 500Hz or higher, it can use quite a bit of CPU.

 

You can check the scan period by right clicking on the cRIO controller in the project and selecting Properties >> Scan Engine.

 

If you don't need a high I/O scan rate, slow down the scan period and you will get CPU back. 

 

 Kurt 

Message Edited by jkurtw on 02-25-2009 09:29 PM
Message 18 of 18
(1,113 Views)