LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

RT: Forcing RT to ignore first NIC

Hi, I formatted a Compact PCI PC using the RT utility USB disk as I've done on many other systems.

This worked well and once it booted off the hard drive RT reported 3 MAC addresses of which it enabled the first one (and assigned an IP address) and disabled the other two.  

My problem is that I only have physical access to the second and third ethernet ports - the first is routed to the backplane or rear-IO on this processor and I do not have a rear-IO connector for this device.  This means that MAX will not see the remote device and I cannot install any software onto it.  

Is there any way to force RT to rather use the second or third network port? Possibly an ini file I could copy to the USB stick?

 

Any help will be appreciated.

0 Kudos
Message 1 of 10
(980 Views)

Is it possible to dissable the first NIC and enable the second or third? Each port should have it's own Ethernet conection so it should be a game of Enabling one and testing all the ports till you find the right one.

 

<Brian A | Applications Engineering | National Instruments> 

0 Kudos
Message 2 of 10
(946 Views)

That is a good idea but I do not know how to do this.  There seems to be no option in the bios to disable ethernet ports, and as I cannot see the device in MAX I cannot set anything up from there.  How do you suggest I go about disabling the ports?

0 Kudos
Message 3 of 10
(936 Views)

That is a good idea but I do not know how to do this.  There seems to be no option in the bios to disable ethernet ports, and as I cannot see the device in MAX I cannot set anything up from there.  How do you suggest I go about disabling the ports?

0 Kudos
Message 4 of 10
(936 Views)

You should be able to set up the secondary ethernet conection through Measurement & Automation Explorer but you will have to set it as a Static IP address. Just make sure the static IP is on the same subnet as the host PC and then you should be able to comunicate with the Real-Time controler over the second ethernet port. 

 

<Brian A | Applications Engineering | National Instruments> 

0 Kudos
Message 5 of 10
(917 Views)
See the problem is that I cannot see the device in MAX in the first place as the second and third ethernet connectors are both disabled by default when you load RT onto a desktop PC. The first ethernet connection on this PC is not wired to a rj45 connector but is wired to the internal backplane. I need to get the second ethernet connection activated WITHOUT using MAX maybe by using an INI file on the filesystem of the RT harddrive?
0 Kudos
Message 6 of 10
(910 Views)

Can you choose to turn off the primary ethernet adaptor through the computers BIOs menu? 

 

<Brian A | Applications Engineering | National Instruments> 

0 Kudos
Message 7 of 10
(899 Views)

Hi Brian, this would have been a solution but after I discussed this with the manufacturer it seems one can only disable the ethernet ports that reachable from the front and not the primary (which is the one I cannot physically reach).  

 

Is there any way to make the pharlap kernel ignore this first NIC?  Maybe using a ini file that is loaded onto the usb boot disk?

0 Kudos
Message 8 of 10
(854 Views)

That is unfortunate that you cannot change it through bios.

 

It might be possible to change the port used by changing an ini file. 

The network adapter settings are stored in netconf.ini which can be found under the ni-rt/system/ethernet folder. 

 

Open that folder and change the value of the first MAC address in the file to the MAC address of your primary NIC. Then change the MAC address after "PrimaryMAC=" to the MAC address of a NIC that you would like to use. 

 

Example: Original

 

[0000000000000]
Mode=Disabled
[General]
MACAddresses=0000000000000;999999999999;
PrimaryMAC=999999999999


 

 

Example: Updated

 

[999999999999]
Mode=Disabled
[General]
MACAddresses=000000000000;999999999999;
PrimaryMAC=0000000000000

 


 

Save that file back to the original location and reset the controller. This should change the primary Ethernet connection to a different NIC.

 

<Brian A | Applications Engineering | National Instruments> 

0 Kudos
Message 9 of 10
(842 Views)

Just to wrap this one up - I managed to install RT on this system by moving the hard drive to another PC (a normal desktop with all the ethernet ports

easily available).  Here, from MAX, I modified the netconf.ini file by 'file transferring' it to my local drive, changing it and transferring it back.  I then plugged the hard drive back into the original box and it then saw the 3rd ethernet port (available on the from panel) as the primary and I was able to install the RT software.

 

Thanks for the help.

 

netconf.ini file:

 

[00C088008083]
IP_Address=10.10.10.77
Mode=TCPIP
Subnet_Mask=255.255.255.0

[00C088008081]
IP_Address=10.10.11.77
Mode=TCPIP
Subnet_Mask=255.255.255.0

[00C088008082]
IP_Address=10.10.12.77
Mode=TCPIP
Subnet_Mask=255.255.255.0

[General]
MACAddresses=00C088008083;00C088008082;00C088008081;
PrimaryMAC=00C088008083

 

0 Kudos
Message 10 of 10
(733 Views)