LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

RS485 Communication - Parity Error

Solved!
Go to solution

Did you try RavensFan's 2 ideas?

 

"First, make sure you have parity error replacement DISABLED.

 

If you do not care about that 9th bit, then just read 8 bytes (do not use bytes at port), and ignore the parity error that you are guaranteed to get.  Somewhere there is a function called Clear Specific Error.   You could also use the general error handler.  Or unbundle the error code and feed it to a case structure that sends no error if it is a parity error, and passes through all other errors and warnings."

.




0 Kudos
Message 21 of 24
(680 Views)

Kodester,

 

I have double checked the disabled function.

 

Right now i'm using case structure to bypass my error so that I can write something on the default case.

0 Kudos
Message 22 of 24
(667 Views)

So everything is working just fine now.  Your question has been solved.

0 Kudos
Message 23 of 24
(663 Views)

RavensFan,

 

At this point I hope this is the best solution as you suggested. I'll go head and accept the solution and close it. Later when I find something new I'll addup to the post.

 

Thank you all!!

0 Kudos
Message 24 of 24
(654 Views)