LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

RIO I/O control not working

Solved!
Go to solution

I have created a Labview program to control the USB-7856 FPGA device on a PC and converted it to an executable file. I have verified that this executable file works fine on this PC. However, when I used this program on another PC, the RIO I/O controls on the front panel stopped responding. The down arrow button on the right side is grayed out, and when I click it the list of RIO devices does not appear. If anyone knows the cause of this problem, please let me know. Attached is the screen shot of the grayed out control.

0 Kudos
Message 1 of 6
(497 Views)

Does your deployment PC have the NI-R Series RIO driver installed?

Is your USB-7856 detected in NI MAX on the deployment PC?

0 Kudos
Message 2 of 6
(448 Views)

Thank you for the reply.

Yes, my device is recognized as "RIO0" in NI-MAX.

Also, I installed the NI-R Series RIO driver as attached.

First, I installed the latest version (ver.2023) but it didn't work.

Then, I tried (installed) ver.21.3 after uninstalling ver.2023.

 

0 Kudos
Message 3 of 6
(437 Views)

My post was unclear.

By "it didn't work," I meant that the gray-out of RIO I/O control occurred.

0 Kudos
Message 4 of 6
(433 Views)
Solution
Accepted by nobuyuki

Wow.  That is the most chaotic installation of LabVIEW I have ever seen!  You appear to have one version of LabVIEW (2019), 13 (!) versions of LabVIEW Runtime (from 8.5.1 to multiple copies of LabVIEW 2023 (and both 32-bit and 64-bit), three components of DAQmx (all 2019), VISA (and VISA Runtime) 2023 Q3, ...

 

Here's my suggestion.  Try this on a PC without LabVIEW (or on a VM without LabVIEW) or on a PC where you don't mind completely uninstalling LabVIEW (I'd advise not doing this right away on your Production machine).

 

  1. Completely uninstall LabVIEW.  There is (as far as I know) only one safe way to do this.  Since LabVIEW 2017, NIPM has become the LabVIEW Installer/Uninstaller.  Open NIPM, make sure the little box at the top is checked (or maybe unchecked -- I can't open NIPM right now, but you want it to "include everything").  Then click the "selector box" on the left that "selects everything" (it won't let you select NIPM, which is OK), and click Next until the un-installation begins.  It may take quite a while.
  2. Reboot when it finishes.  Run NIPM again.  Repeat Step 1 if there is anything left except NIPM.
  3. When only NIPM is left, select it, read the warning, then proceed.
  4. At this point, you want Control Panel.  Go to the Search Bar and type "Control Panel".  Click "Programs and Features".  Look for "NI Software" or "National Instruments Software".  See if there are any more (pre-NIPM) stuff to be uninstalled.  Uninstall them, and reboot.
  5. DO NOT TRY TO EDIT THE REGISTRY OR DO ANY "FORCE" REMOVALS.  Doing so runs the risk of forcing you to wipe the C: drive, reinstall Windows, reinstall everything else, and reinstall your Profile and stored data.
  6. Now you can install (I recommend a single) "Clean" version of LabVIEW.  I recommend that you install 32-bit LabVIEW.

Bob Schor

0 Kudos
Message 5 of 6
(395 Views)

Thank you for your suggestion.

I agree that my installation is terrible.

 

I cannot stop the experiment we are conducting now,

so I will follow your instructions when it is over.

I think it will fix the issue.

0 Kudos
Message 6 of 6
(357 Views)