LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Quick Drop list won't update during search

Solved!
Go to solution

My Quick Drop started acting up today.  Normally, when I begin typing, the list under the search box will update to show all of the possible matches.  This is no longer happening.  It still tries to autocomplete the search field, but the list doesn't update.  [screenshot attached]

 

I'm running LabVIEW 2009 SP1 on Windows XP 32-bit.

 

For what it's worth, LabVIEW crashed went on vacation early last Wednesday evening, just before I was getting ready to leave for the weekend.  When I returned to work this morning, Quick Drop was no longer functioning properly.  I don't know if these two events are related, but I figured that it was a possibility.

 

I've tried rebooting my PC and renaming the LabVIEW.ini file and restarting LabVIEW with a fresh configuration, but no luck.

 

Any help would be greatly appreciated!

 

 

 

 

0 Kudos
Message 1 of 9
(1,620 Views)

Quick Drop uses a plug-in to the NI-SEARCH mechanism (added in LabVIEW 2009 to add more relevance to palette searching) to populate the search results in LabVIEW 2009.  I added a way to disable this mechanism in LabVIEW 2010, but in LabVIEW 2009, I don't have an easy way for you to troubleshoot to see if NI-SEARCH is the problem.

 

Can you repair your LabVIEW 2009 installation and see if that fixes the problem?  Another way to see if it is related to NI-SEARCH would be to see if you have any problems performing palette searches.

 

Keep me posted,

-D

DNatt, NI
0 Kudos
Message 2 of 9
(1,601 Views)

 


@Darren wrote:

 

Can you repair your LabVIEW 2009 installation and see if that fixes the problem?  Another way to see if it is related to NI-SEARCH would be to see if you have any problems performing palette searches.


I've tried repairing the installation using the LabVIEW 2009 SP1 downloader (found here), but after running through the setup it appears to skip through the installation and head straight to the device drivers installer.  I don't have a physical disk for SP1 available, otherwise I would try repairing from that.

 

 

The palette search seems to work just fine; the list updates with every character I enter into the search field.

 

I had another issue with the Quick Drop at around the same time that may or may not be related.  The QuickDropPosition in the LabVIEW.ini file was somehow set to "-5,-31,366,303", hiding the title bar off-screen and making it impossible to move the Quick Drop window, even when holding Alt+Space and selecting Move from the menu.  This problem was easy to fix, but I still wonder if it could be possible that both issues could have been caused by the same event.

0 Kudos
Message 3 of 9
(1,579 Views)

Thanks for the additional info.  I don't think the window position issue is related to the search results updating issue.  (Incidentally, there's a fix in LabVIEW 2010 for when there are bad window coordinates for the Quick Drop window stored in the INI file).

 

Anyway, I still think that NI-SEARCH is the culprit, but since you can't reliably repair your installation, we can't know for sure.  So instead, I'd like you to try the following workaround:

 

1.  Go in [LabVIEW 2009]\resource\dialog\QuickDrop and rename QuickDrop Launch Window.vi to be QuickDrop Launch Window.bak.

2.  Save the attached QuickDrop Launch Window.vi below to [LabVIEW 2009]\resource\dialog\QuickDrop.

 

Now try Quick Drop and see if the results update properly.  Basically, I modified the shipping version of the main Quick Drop UI to use the old LabVIEW 8.6-style of matching results instead of the NI-SEARCH mechanism.  Let me know if this fixes the problem.

DNatt, NI
0 Kudos
Message 4 of 9
(1,559 Views)

 


@Darren wrote:
Let me know if this fixes the problem.

Nope, it still behaves the same way.

 

0 Kudos
Message 5 of 9
(1,554 Views)

I'm out of ideas, then.  There aren't any relevant subVI calls during the handling of key events, which means you're running exactly the same code that I am.  A repair of the LabVIEW installation remains my only other suggestion.

DNatt, NI
0 Kudos
Message 6 of 9
(1,550 Views)

OK, I guess I'll just have to see what I can do with it on my end. 

 

Thanks for all of your help.

0 Kudos
Message 7 of 9
(1,542 Views)
Solution
Accepted by topic author nft08

It appears that I've solved the issue. 

 

Yesterday, I noticed that the Quick Drop worked when I took my laptop out of my cubicle to do some work in another location.  When I booted my laptop up in my cubicle this morning, however, the problems came back.  Apparently, the problem was related to the use of the docking station for my laptop.  Something in the configuration for the "docked" hardware profile must have been corrupted, causing the Quick Drop issue, among other buggy problems (for instance, not allowing me to click and drag the mouse to highlight text).  I disconnected the laptop from the docking station, and everything suddenly worked fine.  Once I reconnected the laptop to the docking station, it apparently overwrote the corrupted "docked" hardware profile, because the next time I booted the computer while connected to the docking station, everything worked fine.

 

Problem solved!

 

 

Message 8 of 9
(1,469 Views)

Thank you very much for posting the solution to your issue.  I don't really understand how hardware profiles could cause a UI problem like this, but apparently you were seeing other anomalies as well (like the text highlighting issue).  At any rate, I'll keep this thread in mind if I hear anybody else having similar problems with Quick Drop in the future.

DNatt, NI
0 Kudos
Message 9 of 9
(1,452 Views)