Showing results for 
Search instead for 
Did you mean: 

Project wont connect as EXE, is it LVOOP?

Go to solution

I've been through huge arcfhitectural changes in the past few weeks, and finally settled on a starting point. I decide I'll start by building an EXE to talk to my Delta Motion RMC75. The drivers for this are Plug and Play certified and I've used them before with great success, but never turned that Project into an EXE.


I run the top level VI and everything works great. I build the executable, and it builds without errors. I run the executable, and it runs without errors, but it doesn't connect. It doesn't even wait 3 seconds for a timeout from the connection VI, it just passes right through it like its not there. And then none of the drivers inside the loop error out, which they should obviously do, since there is no connection.


The reason I am certain there is no connection is that immediately upon connection, a couple of relays start making noise and things start humming, which does not happen when running the EXE. It acts like the driver VI's are all missing. All of the rest of the functions work.


I'm afraid that this is a result of the drivers being written in LVOOP, but I'm hopeful that I am just missing something in the application builder. Any thoughts?


Here is the short list of things I have tried:


1. Include the .lvlib that contains all of the drivers in the project. I took this back out after reading another thread


2. I unchecked all of the boxes in additional exclusions so that now, all polymorphic instances and unused members are included


3. Moved the destination of the dependencies (which contain the .lvlib of the drivers) around. The lvlib being contained here is the reason for 1.

0 Kudos
Message 1 of 3

Here are a few more notes on this:


4. I tried building an installer after reading another post, no joy


5. I tried mass compiling all of the files in the project from the Labview welcome screen, no problems


6. After researching how to debug an EXE, I started the VI on the development machine, and then went to the debug window, and as it gets done connecting, everything freaks out a little, and a window comes up saying:


Compiler Error. Report this problem to NI Tech Support,


Event Data copy, err=1


followed by a second pop up that says:


Fatal Error Occurred during operation, closing connection


at which point labview crashes.

Message Edited by deskpilot on 01-29-2010 01:06 PM
0 Kudos
Message 2 of 3
Accepted by topic author deskpilot

Apparently this was a known bug with the Delta drivers, and they have released a patch. Here is the link in case anyone else comes across this:

Message Edited by deskpilot on 02-01-2010 01:02 PM
0 Kudos
Message 3 of 3