Showing results for 
Search instead for 
Did you mean: 

Programmatically deploy the RT-VI onto cRIO 9074



because I became annoyed of deploying the VIs for the Real-Time-Target on my cRIO-9074 every time I changed a little,

I tried to deploy the main VI programmatically. I tried to use this community solution:

but it won't work. If I wire the path of the project on the Host-PC (like c:\users\...) i got the following error message:


Error 8 on method node "open project", file permission error.

NI-488: DMA Hardware-Error


Can this be caused by the opened project? I don't have the RT-VI opened...


I also tried to choose the VI on the RT-Target, by wiring IP-adress to OpenReference and changing the project path to c:\ni-rt\startup\, but that won't open a valid project reference.


Maybe I have to change some settings in my project?



0 Kudos
Message 1 of 2

Hey there,


I got it managed, I had to use the property node ActiveProject and then Path instead of OpenProject.


But now there occurs an error with the shared variables, in DSM the library is marked as "Evaluation in another application (offline)". I deploy the programmatically, when I do the same manually, the shared variables work fine





Edit: In DSM, the shared variable library is added, but not started. Is there a possibility to start shared variable processes programmatically?

0 Kudos
Message 2 of 2