LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with SD6 Teleop Example - Steering frame

Highlighted

Hello all,

I am trying to use to the sd6 teleop example to control an sd6 robot. When I run the robot main vi, it runs with no errors. But when I start the host main vi, it runs for a couple of seconds, giving me a stream of the camera on the robot, then stops and I get an error in robot main, 1073807343, VISA Write in SD6.1 Motor Drivers.lvlib:Trigger estop.vi-> Robot Main.vi. Possible Reason: VISA Insufficient location information or the device or resource is not present in the system.

 

When I try and track down the source of this error, I get to the convert drive command to motor velocities vi, and when running that vi on its own, I get error 310082, the steering frame is invalid, steering frames must contain at least one wheel. Similarly when running the check for valid steering frame vi, I get the same error. Anyone have any idea of what is going wrong or what I can do to fix this?

0 Kudos
Message 1 of 4
(604 Views)

What about the Create Steering Frame vi? Could you verify that it is actually creating a valid frame? After all, that's the one that is being input into the Convert drive command to motor velocities vi. I could not really look into it because I don't have the robotics module installed so I don't have actual access to the VIs. If you cannot figure it out, I will try to install it to see if I can find anything.

 

Regarding the VISA error, I really could not find anything wrong on the VIs, so my guess is that if you are able to solve the steering frame issue it could be easier to fix the other one.

Camilo V.
National Instruments
0 Kudos
Message 2 of 4
(558 Views)

Thank you for the reply. I am still very inexperienced with labview so if anything I am saying does not make sense just let me know and ask for further clarification. So, when I go to the create steering frame.vi I get a window popup with 4 different vis- Create user defined steering frame, create differential steering frame, create ackermann steering frame, and create mecanum steering frame.

 

When I go to create differential steering frame, the vi runs with no errors. When I go to the create user defined steering frame, in the user interface, there is a box that says wheels, and has an input. I can manually put in two wheels, but when I just open it shows 0 wheels. In either case, when I run it i dont get any errors. I am not sure how to look at what this vi is outputting in the 'steering frame out' file.  Even if I manually change to two wheels on the user created steering frame vi, I still get an error in the check for valid steering frame vi.

0 Kudos
Message 3 of 4
(544 Views)

Hello eephysicspaul

 

Could you provide the error code (or message) you are getting? One detail I would like to clarify since I did not see it mentioned, you are programming the DaNI right?

 

Regards

Frank R.

0 Kudos
Message 4 of 4
(509 Views)