LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with PCI-7811R after LabVIEW upgrade

Solved!
Go to solution

Hi

 

I have been using a PCI-7811R under LabVIEW 8.2 for some time without difficulties. However, I have just upgraded to LabVIEW 2009 and it seems to have stopped working.

 

I tried to run some old code (that worked before) and I get the attached error. I try and locate the PCI-7811R in MAX ver. 4.7.7 and it's not there.

 

Any suggestions?

 

Gary

0 Kudos
Message 1 of 17
(1,516 Views)

Just a guess- but a good oneSmiley Wink the DAQmx (8.9.5)or NI-RIO (3.5) driver that installed with LabVIEW 2009 (8.9.5) does not support the PCI 7811R. 


"Should be" isn't "Is" -Jay
0 Kudos
Message 2 of 17
(1,506 Views)

Thanks for that.

Assuming that you are correct, will it be possible for me to uninstall certain components and re-install older versions to deal with this problem? If so, which components should I uninstall and what are the latest version(s) that do support the 7811R?

Cheers,

Gary

0 Kudos
Message 3 of 17
(1,488 Views)

Great question!

 

Poking through the read-me's for the various drivers left me without a clue.  Hopefully, your SSP is paid up and you can visit Here

 

That question would be better handled by a NI App engineer.   I could try shouting for one.  OH App Eng! Little help please.


"Should be" isn't "Is" -Jay
Message 4 of 17
(1,483 Views)

Hi Gary,

 

I can let you know that minimum version of NI-RIO for the PCI-7811R is 1.3. all other releases after this are supported.

Minimum version of LabVIEW is 7.1, FPGA module is 1.1, LabVIEW Real-Time Module is 7.1.

 

This information can be found here: ftp://ftp.ni.com/pub/devzone/tut/crio_software_versions.htm

 

Has this answered your query?

 

Many thanks,

John McLaughlin
Academic Account Manager
National Instruments UK & Ireland
0 Kudos
Message 5 of 17
(1,457 Views)

Thanks for the help. I uninstalled everything, then re-installed LabVIEW base and the old RIO driver 2.1.3 but to no avail.

 

If I uninstall everything again and then install LabVIEW base only, what is the minimum amount of other software/drivers thatI need to get the FPGA working again? Also which versions?

 

Cheers,

Gary

0 Kudos
Message 6 of 17
(1,427 Views)
Did you also reinstall the LabVIEW FPGA module and the latest version of
NI-DAQ that supports the 7811?

"Gary7811" <x@no.email> wrote in message
news:1296137405378-1429798@exchange.ni.com...
> Thanks for the help. I uninstalled everything, then re-installed LabVIEW
> base and the old RIO driver 2.1.3 but to no avail.
> &nbsp;
> If I uninstall everything again and then install LabVIEW base only, what
> is the minimum amount of other software/drivers thatI need to get the FPGA
> working again? Also which versions?
> &nbsp;
> Cheers,
> Gary


0 Kudos
Message 7 of 17
(1,414 Views)

I installed the FPGA module and an old version of DAQ. I'm not sure which the latest compatible version of DAQ is, so I installed an old version that worked previously. If you could tell me the latest versions of all the modules/drivers/etc that I need to get my 7811 working under LabVIEW 2009, that would be ideal.

0 Kudos
Message 8 of 17
(1,401 Views)

Hi Gary,

 

From looking at this chart I can tell you that Daqmx 9.2.3 is the latest driver compatible with LabVIEW 2009. Besides that, the latest compatible NI-RIO driver can be found here.

 

This should get you up and running, I hope this has helped!

 

Many thanks,

 

John McLaughlin
Academic Account Manager
National Instruments UK & Ireland
0 Kudos
Message 9 of 17
(1,395 Views)

Thanks for that. Just to confirm (as I only want to install ONE more time!), I should install the following in this order:

1) LabVIEW base
2) LabVIEW f3 patch that is recommended when I do the initial install
3) LabVIEW Service Pack 3
4) DAQmx 9.2.3
5) NI-RIO 3.5.1
6) FPGA Module


Will it be okay to install the version of the FPGA module from the LabVIEW 2009 CD pack?

0 Kudos
Message 10 of 17
(1,388 Views)