Showing results for 
Search instead for 
Did you mean: 

Problems getting rsspecan drivers in functions palette



I downloaded the rsspecan drivers from the Rohde & Schwarz website and followed the "How to use the Rohde and Schwarz LabVIEW instrument drivers" guide to install them correctly. I unpacked the zip file in 'C:\Program Files\National Instruments\LabVIEW 2009\' thus placing the correct files in user.lib and instr.lib folders;


Upon starting LabVIEW, the express VI "Configure" is installed correctly under 'User libraries'. In the Instrument I/O palette however, no rsspecan driver is visible although there is a massive amount of extra folders in the instr.lib folder. .


Any ideas on what causes this? I installed several other instrument drivers and never had problems so far... Also, the rsspecan seems a pretty elaborated driver so it surprises me I'm having problems with it.


Best regards,



0 Kudos
Message 1 of 7

Hello Filip,


Can you post the link from where you downloaded the driver?


I found some possible candidates, but I want to make sure I'm testing the right version of the driver.

Kind Regards,
Thierry C - CLA, CTA - Staff R&D Engineer, RF Semiconductor Test - National Instruments
If someone helped you, let them know. Mark as solved and/or give a kudo. 😉
0 Kudos
Message 2 of 7

Hi Thierry,


I found them at the Rohde & Schwarz page (where I also downloaded R&S drivers before).|-Drivers-|-25-|-987-|-987.html


I also tried to install them on a windows xp laptop with LabVIEW 8.5, there it worked fine immediately.


Doing exactly the same thing on my laptop running Windows 7 and labview 2009, it didn't work. I did find a workaround however by using "Tools -> Advanced -> Edit palette set" and then by rightclicking the palet and "Insert -> subpalette", I linked it to the path where the dir.mnu files were. This seems to work fine.


However, I still find it odd it didn't do the job the normal way.


Thanks in advance,



0 Kudos
Message 3 of 7

Hi, there should be no additional measures nessesary to have the instrument driver in the menu palette. Please double check your instr.lib and usr.lib folder contents. It should look like in the attached screencopy.

BR juergen

0 Kudos
Message 4 of 7

thanks for your reply Juergen. That's exactly what I thought, as I already installed other drivers this way. my folders look exactly like your screenshot.

For now, it works fine the way I worked around it. It also seems that most of the rsspecan driver folders are just empty...






Download All
0 Kudos
Message 5 of 7

Hi, I suppose something went wrong while extracting the package. I double checked the latest version of the driver - especially the Configuration folder, and everything looks fine at my machine. Could you please download the driver a again and reinstall/extract the driver in the according folder again?

BR juergen

Download All
0 Kudos
Message 6 of 7

ok, apparently something went wrong indeed (three times in a row :)). Now everything got installed smoothly! Thanks a lot for the effort!

0 Kudos
Message 7 of 7