LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Probleme au lancement du programme

Solved!
Go to solution
Highlighted

Bonjour, je rencontre un problème avec une partie de mon programme, au niveau de l’assistant DAQ.

 

Contexte : J'aimerai pouvoir modifier la luminosité d'une lampe.

Pour ceci j'envoie une information 0/10V à un gradateur puis cette information va dans la lampe.

 

Je pense que je problème vient du paramétrage de l'assistant DAQ, mais je n'arrive pas à résoudre ce problème.

0 Kudos
Message 1 of 3
(104 Views)
Solution
Accepted by topic author Projet-Mini-Jeux
05-23-2019 04:07 AM

en effet, c'est bien dans le paramétrage de l'assitant DAQ qu'il y a un soucis, dans "type de cadencement" > "mode de génération" tu as séletionné "N échantillons", donc ensuite dans ton VI, l fonction DAQ assistant s'attend à recevoir  un tableau et tu lui donnes seulement une valeur (celle de ton bouton rotatif), il faut donc que tu modifies le mode de génération pour indiquer que tu veux écrire une seule valeur à chaque appel de ta fonction DAQ.

De plus tu devrais mettre un cadencement explicite dans ta boucle while car sinon au va tourner aussi vite qu'elle peut et donc consommer pas mal de ressources sur ton PC.

 

Enjoy


We have two ears and one mouth so that we can listen twice as much as we speak.

Epictetus

Antoine Chalons

0 Kudos
Message 2 of 3
(84 Views)

MERCI BEAUCOUP TITOU ! En changeant le mode génération çà fonctionne Smiley Happy

0 Kudos
Message 3 of 3
(74 Views)