LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with "defer panel updates" prorperty

Hi,

 

I use  "DeferPanUpdts"  (set it true or false) in a vi to smooth FP updating,  and it works perfectly. The problem is after I insert it into a subpanel of a parent vi,  "DeferPanUpdts" property doesn't work any more.

 

If I set the parent vi "DeferPanUpdts" true, the child vi FP doesn't update correctly and controls don't response.  If I set it false, "DeferPanUpdts" in child vi seems doesn't work.

 

It seems the parent vi overrides the child vi defer property.   Anyway to disable that?

 

Thanks a lot for any help.

 

 

Anne

0 Kudos
Message 1 of 5
(2,689 Views)

Hello Anne,

 

What version of LabVIEW do you have? From the post below, it seems that you would need to have both the Parent VI and subpanel VI to be set to defer updates. You may also check the following knowledge base article on this issue.

 

KB Why is the Defer Panel Update Property Not Working?

http://digital.ni.com/public.nsf/allkb/F0B8453E5DEA09E986257115006E9F9B?OpenDocument

 

 Defer Panel Updates Panel Property Question

http://forums.ni.com/ni/board/message?board.id=170&requireLogin=False&thread.id=167173

Andy Chang
National Instruments
LabVIEW Control Design and Simulation
0 Kudos
Message 2 of 5
(2,641 Views)

Hi Andy,

 

Thanks for your reply.

 

I am using LabVIEW8.5.1.  It really doesn't work.   I am not sure why.  If I take the child vi out of subpanel, it works perfectly.  If I insert it into subpanel, it doesn't work.

 

 

Maybe it is because the indicator is quite complex?  It's an array of cluster with 17 elements (string, 4 image ring, 4 number, 4 boolean).   I couldn't think of other reason.

 

Could you please try the similar case?  Any other idea?

 

Thanks a lot.

 

Anne

0 Kudos
Message 3 of 5
(2,633 Views)

"National Instruments Support - Please respond to this thread to confirm the problem discussed above has been reported to R&D. If yes, include the CAR number, if not, an explanation (e.g. being investigated, but not reported yet). If you need additional information to proceed, please indicate what is needed."

 

Could you please investigate this issue further. The KB you cited indicates this issue was fixed in LV 8.2. The original poster indicates they are using LV 8.5. I beleive I also ran into this issue with LV 8.5 and commented out the "defer FP updates' in a recently delivered app. In my case i was using nested GUI ie

 

GUI >>> Tab Control >>> Sub-panel >>> Sub-panel

 

Thank you,

 

Ben

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
0 Kudos
Message 4 of 5
(2,610 Views)
This issue was reported to R&D (ID # #57403). It looks like it was fixed in Labview 8.6. Has anyone had a chance to try this out on an 8.6 system?
Misha
Message 5 of 5
(2,586 Views)