LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem when load LabVIEW Packed Library in TestStand

Highlighted

Hello,

I created a packed Library in my LabVIEW project through moving all my VIs in the created project library.After that, I can find a .lvlibp file in builds folder. But when I tried to open it with 'Class Member call', I can only see the .lvlibp file in the window. but I can't open it . What is the problem?What is the right manner to create a PPL , in oder to use the VIs in TestSTAND?Thank you for answering.

 

 

 

0 Kudos
Message 1 of 7
(135 Views)

I don't have TestStand installed to check this, but the image you attached shows you browsing the lvproj file, which contains the lvlib file.

You'll need to instead open the lvlibp file. Maybe you already tried this, but the picture doesn't show it.

 

It's certainly possible based on other threads like the following: https://forums.ni.com/t5/NI-TestStand/Using-LVLIBP-with-DLLs-in-TestStand/td-p/3878633 (they had a different and likely more complicated problem with DLL searching, but they used a PPL in TestStand).

0 Kudos
Message 2 of 7
(97 Views)

Hello,

sorry, I used a wrong picture. But it looked the same when I call the .lvlibp. I will read the link. thanks.

Another question. Before I built my LabVIEW project and Packed Library, I have copied my VI Folder and created the project and PPL with the VIs in copy folder. But after that, my old VIs in another folder works differently as before. When I open the VI ,there comes always a window asking for the project library. Is this because, the VIs in both folders have the same name? and the the directory of involved VIs has changed?

I have read that, the VIs in project library will have new names beginning with project lib name.  But it didn't work this way with my VI. Could you pls maybe tell me what was wrong?

0 Kudos
Message 3 of 7
(66 Views)

I'll try break your message up into a few pieces, maybe you can clarify if I misunderstood...

  • You copied all of your files (.vi, .lvproj, .lvlib) into a new directory before building? Or you copied C:\Program Files (x86)\National Instruments\LabVIEW 201x\vi.lib (or similar) to a new directory?
  • You built the lvlibp file (PPL) from the copied set of files. After this, your previous files produced a window when opened. There are a few options here
    • Your VIs expected to find other VIs at a specific location, but instead found them somewhere else. This produces a warning and will change the source files, but doesn't cause an error in general. It often is an indication something isn't as you expected though
    • Your VIs are members of a lvlib file, and the lvlib file was moved. They need to retain membership, so you get a message asking you if you want to remove them from the library or not? In this case, you should follow the instructions/guidelines in the message, but note that this almost certainly isn't intended here
  • As a result, maybe you can explain more why you're trying to move files before building?
  • When you build something from a Build Specification in a lvproj file (Project Explorer view) it is possible (for many build items, including PPLs) to add a prefix to your files, but this isn't the default. The setting can be found on "Source File settings" tab, at the bottom on the right - rename this file for single files, or Apply prefix to all contained items for a (virtual) folder.
0 Kudos
Message 4 of 7
(59 Views)

Hello,

maybe I haven't described it clearly. I think you have understood it correctly with the following point:

'Your VIs expected to find other VIs at a specific location, but instead found them somewhere else. This produces a warning and will change the source files, but doesn't cause an error in general. It often is an indication something isn't as you expected though.' But there was errors.

I had a folder of all my VIs of this project(only VIs, no project library of packed library), we call it 'x'. Because I want to try the PPL building in another folder,then I copied 'x' and  created a new folder 'x copy'.All the VIs in 'x copy' are the same as in 'x'.

Then I built project with VIs in 'x copy', created project library(called y) with all VIs in 'x copy', and then PPL. All these are in 'x copy' saved.

After that, I tried to open my VIs in 'x' folder, the window appears always asking for the project library(which was created with VIs in 'x copy'). If I click cancle,the VIs is opened with errors, that other VIs are not excutable.

 

 

0 Kudos
Message 5 of 7
(57 Views)

So I just tried to reproduce what you found and had no issues, so I guess it requires something a bit more complicated than my very simple test.

Let me just describe what I did and you can tell me if you do anything different:

  1. I created a new empty project (.lvproj) in a new directory (Desktop/test/folder1)
  2. I added two new empty VIs (file1.vi, file2.vi)
  3. I saved the project and closed it
  4. I used Windows Explorer to copy-paste the folder into a new location next to the original (Desktop/test/folder1 - Copy, the default name when I copied)
  5. I opened this new project (test/folder1 - Copy/projectFile.lvproj)
  6. I checked that the files that were loaded were from the copied directory, not the original source. They were.
  7. I created a new library (lvlib file) and saved it.
    1. The location suggested was in the previous folder, Desktop/test/folder1, not "folder1 - Copy". I moved to the new directory and saved the library (myLibrary.lvlib).
  8. I dragged the two VIs into the library
  9. I created a build specification for a PPL, and added the library as the source file, and built the file (by default, Desktop/test/builds/projectFile/My Packed Library/myLibrary.lvlibp)
  10. I closed the project
  11. I opened the original project (folder1, not folder1 - Copy)
  12. I observed no problems, errors or dialogs.

So I'm not sure what happened for you. I suspect some sort of cross-linking, but I don't know how or why. Do you depend on some other already existing PPLs? Changing the relative path can cause a problem if so.

0 Kudos
Message 6 of 7
(50 Views)

Make sure you actually made the library with the VIs in x_copy.  It is sounding a lot like you accidentally used x instead.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
0 Kudos
Message 7 of 7
(48 Views)