LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem installing LINX 3.0 on Raspberry Pi 3

Solved!
Go to solution

It worked with LabVIEW 14 and latest Raspian installed through NOOBS.

I had to modify the Get Device Type VI to recognize the BCM2835 as a Raspberry Pi 2 B.

Also had to create a .so symlink as described in https://labviewhacker.com/forums/viewtopic.php?f=12&t=3018&sid=4da022021ddc64866824cf0ae62d3778 .

 

Next step is to try to run it in LabVIEW 2017.

 

Thanks guys.

Message 21 of 28
(2,019 Views)

Hi. I was able to make it work with LabVIEW 2017 32-bit. For educational purpose only, I used the LabVIEW 2017 run-time found in \Program Files (x86)\National Instruments\RT Images\LabVIEW\2017\Linux\armv7-a.

For the time being, I only testes the blinking led LINX example and file system access, but I assume that most of the libraries would work.

 

Message 22 of 28
(2,010 Views)

Sorry can you explain what you do with the mentioned runtime

do you copy on the RPI 3 or what?

Thanks

0 Kudos
Message 23 of 28
(1,904 Views)

Hello Friend,

 

I was able to successfully deploy a LV code using LINX 3.0 to my Pi3 without any error. At least the host computer says so. However, I am not able to find the deployed VI in the Pi. I assume it should be somewhere in the Pi3. Does anyone know where it goes in the Pi3? Once it is deployed successfully, can I run this Vi next time from the Pi3 itself, without using the host computer once again.

 

In my code, I also need to save the data in a spreadsheet file. Can the Pi3 save the data in the SD card in this case? 

Hope to get some help here. 

 

Thanks

M

0 Kudos
Message 24 of 28
(1,850 Views)

Yes and yes.  You can configure it to run when the Pi starts up by creating a real time application.  I don't remember of the top of my head where VIs are deployed to on the Pi during development, I'm sure another poster will know that, I don't believe it's exactly the same as if you were using a regular RT Linux target like a cRIO, but similar.  You could find out though by deploying a quick debug VI that has the "current VIs Path" primitive and show the deployed path right on the front panel.

 

Accessing the SD card can be done with the File I/O VIs as usual if you know where on the SD card you want to save your data.



I saw my father do some work on a car once as a kid and I asked him "How did you know how to do that?" He responded "I didn't, I had to figure it out."
0 Kudos
Message 25 of 28
(1,847 Views)

Thanks a lot Blackburnite. Finally was able to locate the executable in the Pi. It goes to /home/Lvuser folder  and I can save the files in the same folder. Thanks a lot. 

0 Kudos
Message 26 of 28
(1,840 Views)

I'm currently using labview 2014 32-bit and installed rapbian jessie on mi rpi 3b, but whenever I try to launch example, i still get the same message: "Unknown is not a valid LINX target".

 

How can I fix this?

0 Kudos
Message 27 of 28
(1,825 Views)

You have to poke around in that "Get Device Type" VI posted further down in this thread, that's where it set your device type as unknown.  Your Pi must have a different CPU model than the LINX VIs are expecting.



I saw my father do some work on a car once as a kid and I asked him "How did you know how to do that?" He responded "I didn't, I had to figure it out."
Message 28 of 28
(1,819 Views)