LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem in Interfacing RS-232 to RS-485

Hello,

I tried hard to find an answer for my problem in the old posts but I couldn't so allow me to submit it here:

 

 I am working on a project to control an Inverter (Mitsubishi FR A740) through the PC serial port RS-232 using Labview VISA. The Inverter has an RJ45 8-pins connector (RS-485) and I use an RS-232 to RS-485 Converter cable supplied by the same company.

 

- I adjusted the communication parameters for the serial connection (Baud rate,parity,start bit,data bits,stop bit,flow control) for the Inverter and changed the operation mode as required according to the Inverter-Computer link protocols.

- As a starting point I used the simple and advanced read/write program to check if the communication is initiated successfully, of course I adjusted the parameters to match the one's of the Inverter. I tried to send different formats of messages that contains any kind of error, the inverter was supposed to send back an error code according to the error type. Although I adjust the waiting time properly, I didn't get any feedback from the

Inverter, what could cause the Inverter not to respond at all to the data I send ?

 

Thanks

0 Kudos
Message 1 of 3
(1,169 Views)

Are you sure you are sending the correct strings?

 

For example, A0 in 'Normal' display looks the same as A0 in hex (to the human eye). But they are actually different strings when transmitted.

 

Right click on the string control/constant you are sending and check the string type.

String Type.PNG

 

Does the manufacturer issue any software for the drive? If they do you may want to try using it to prove your wiring/converter settings.

0 Kudos
Message 2 of 3
(1,158 Views)

Thanks !! You just got it ! I guess it's a biggener mistake ! Everything works good now! I actually misunderstood a fundamental thing, that the send data should be in ASCII code !!

0 Kudos
Message 3 of 3
(1,132 Views)