cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Problème création d'executable avec FPGA

Highlighted

Problème création d'executable avec FPGA

Bonjour,

 

J'ai un problème pour créer l'exécutable d'un projet Labview.

 

Dans mon projet,

J'ai un VI FPGA très simple compilé : "rien.VI"

Un autre sous labview classique ouvrant la référence FPGA "rien.VI" : "Temporaire_esclave.vi"

Un autre sous labview classique exécutant "Temporaire_esclave.VI" par l'intermédiaire d'un noeud de méthode : "Interface_tempo.vi"

 

Je créer l'executable de "Interface_tempo.vi" et le problème c'est que quand je lance l'exécutable, alors "Temporaire Esclave.VI" ne s'exécute pas. Pourtant, si je retire le bloc "ouvrir une référence FPGA" dans le programme "Temporaire_esclave.vi", et que je recréé dans les mêmes conditions l'exécutable de "Interface_tempo.VI", alors ça fonctionne. C'est donc la fconfiguration de ce bloc qui devrait être la cause.

 

Quelqu'un pourrait-il m'aider à comprendre d'où vient ce problème? et comment puis-je le contourner?

J'ai Labview 10.0.1 professionnel.

 

Je Joins tout le projet et tous les VI.

 

 

Merci à tout ceux qui m'aiderons.

Cordialement,

Vincent.

 

 

 

0 Kudos
Message 1 of 3
(138 Views)

Re : Problème création d'executable avec FPGA

Hello Vince,

 

First I'll ask you to write in english as we're in the international part of the forums. If you want some help in french specifically, you'll need to go there.

 

I have a few questions and tests that you could perform to debug this :

 

- Does the Temporaire_esclave.vi work ? If so, it will mean that the fpga vi is doing fine, and the calls are supposed to be the issue.

- Try to link your fpga reference to a bitfile and not to a VI. What's the output ?

- Try to execute the calling VIs from the RT part ans see what happens.

 

Regards,

 

 

 

Eric M. - Senior Software Engineer
Certified LabVIEW Architect
Certified LabVIEW Embedded Developer
Certified LabWindows™/CVI Developer

0 Kudos
Message 2 of 3
(122 Views)

Re : Problème création d'executable avec FPGA

Thank you Eric for your answer and sorry for the question in french.

 

The problem  was that when we want to use the methode "open VI reference" and "execute VI", the VI called must be in "Starting VIs" in "Source Files" when executable is created.

 

Best Regards,

Vincent.

 

 

 

 

0 Kudos
Message 3 of 3
(115 Views)