LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Print Report not working in Run Time

Hello,

The Print Report vi doesn't seem to work in the runtime environment. To test it, I made a simple vi that prints the text "Test Page." It works fine (prints the test page to the default printer) on my development computer (as a VI and an executable), but the executable does not print on any computer that has the runtime environment only.

Any ideas to get this working would be greatly appreciated.

Thank you,

Tom S.
0 Kudos
Message 1 of 4
(1,365 Views)
Tom, go to NI's knowledge base and do a search on Print Report.vi There are a lot of problems like yours.
0 Kudos
Message 2 of 4
(1,365 Views)
I had the same problem and did not solve it. I had to use Excel report instead of Standard report to print through Excel.
NI has a lot of problems with report generation tool. I had straggled with enormous amount of problems when switch from LV 6i to LV6.1. Currently I have the same kind of problem. Everything works fine on my comuter, but does not work in Run-time environment.
Good luck,
and please share any information tou will find.

Peter.
0 Kudos
Message 3 of 4
(1,365 Views)
Problem Solved:

After uninstalling a previous version of Labview Runtime from the target machines and installing the newest version (which is consistent with my development environment) on the target machines, the Print Report.vi and all other report generation VI's I use seem to work fine.

Also important is to make sure that the lvrt.msi file on the development machine is up to date and consistent with the version of runtime on the target machines. This does not update automatically when upgrading to a newer version of labview (at least not when I updated from 6i to 6.02). It must be manually downloaded and inserted into the proper folder.

Thank you Ray at NI support.

Tom S.
0 Kudos
Message 4 of 4
(1,365 Views)