LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Post-Install Batch File Won't Run

Ok here's the deal. I have created an application that needs a little "cleanup" after the installer finishes. To handle this operation, I created a batch file and told the LV installer to run it after the installation. This works fine on every computer I have tried it on ---

 

Except One

 

Thinking that there might be a problem related to the commands themseloves, I added echos to a log file to save any errors that might occur and to save basic information like paths. However on that ONE computer I don't get the log file even being created, which says to me that the batch is not being executed. However, If I go to the installation direcctory and run it manually, it runs, it does what it is supposed to do and it  stops.

 

The computer this happens on is a corporate laptop that is configured interms of security and permissions like every other corporate laptop. 

 

I am officially confused. Any ideas? WAGs? Suggestions? Recommendations? 

 

Mike...


Certified Professional Instructor
Certified LabVIEW Architect
LabVIEW Champion

"... after all, He's not a tame lion..."

For help with grief and grieving.
0 Kudos
Message 1 of 3
(1,552 Views)

I remember years ago when this feature first came out I tried it with a batch file and I thought it didn't work, and that it only supported running an EXE not thing else.  Since then they apparently fixed that.  So my only suggestion is maybe to try to run an EXE instead of a batch file?  Of course it sounds like it is working on other machines so I doubt that is it.

 

What about UAC?  You say it is a corporate machine so I doubt you can, but maybe lower the UAC to nothing and see if it works.  Of course if it doesn't that probably isn't a good solution.

 

Anti-virus running?  Some have a log of the things it blocks, and it might list the fact that it prevented a batch file from running.

 

The only time I ever used this feature on an EXE I don't remember it not running on the dozen or so PCs I used it on.

0 Kudos
Message 2 of 3
(1,544 Views)

Does the batch file work if you put it in the startup dir?

 

If it does, then you can add the path to registry => run once.

And ask user to reboot.

 

 

George Zou
0 Kudos
Message 3 of 3
(1,527 Views)