LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Poor quality sinewave output with cDaq

Solved!
Go to solution
Solution
Accepted by topic author Doug_1970

So here is what I'm seeing (attempting to reproduce with my USB 6343, as I don't have a cDAQ chassis and module handy):

 

When I run your example as posted, I get chopped up behavior.  I see portions of the waveform repeated, then updated, repeated... wash, rinse, repeat..

When I check set 'Regeneration Mode' to 'Do not allow regeneration', this behavior goes away.  I also do not see this behavior when running the example VI I referenced earlier.

 

When looking at the output of your 'simulate signal', I see that it is outputting a waveform of 1000 points.  With regeneration enabled, these same 1000 points are getting regenerated until your loop iterates and data is re-written.  With this setup, only data which is written as complete periods will appear the way you'd like.

 

Things that appear to help:

In 'Simulate Signal', uncheck 'Automatic' for 'Number of Samples, and set it to something bigger.

Changing 'Regeneration Mode' to 'Do not allow regeneration' **Just changing this one setting allowed your VI to work for me.

 

Dan

 

 

Message 11 of 15
(388 Views)

I have tried the example file posted earlier and everything works fine. I will try the other suggestions now and hopefully will get everything working.

 

I've posted some examples of the waveforms that I have been experiencing with different settings of the sine generator and analog output.

0 Kudos
Message 12 of 15
(384 Views)

Dan,

 

Thanks - that has fixed the problem.

 

Although I'm sure I tried that yesterday with no difference -  I'm pretty sure I must have closed the window after selecting 'no generation' instead of clicking 'ok'.

 

Apologies, and thanks for your patience.

0 Kudos
Message 13 of 15
(374 Views)

No worries... I've done that 100 times.  Glad to hear that you've got it working!

 

Dan

0 Kudos
Message 14 of 15
(371 Views)

@Doug_1970 wrote:

If I enter any value with a decimal place, then the frequency just defaults to the next highest whole number - i.e. if I enter 0.2Hz, then I get a 1Hz output.



I don't.

Thusly!


"Should be" isn't "Is" -Jay
0 Kudos
Message 15 of 15
(366 Views)