LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Parallel ActiveX instances

Hello,

 

I am trying to run two Signal Recovery 3830 multiplexers using a single Labview VI, but I have run into repeated difficulties.  The instrument manual says to simply open up multiple instances of the instrument's ActiveX library (SR3830Comms) to communicate with multiple multiplexers.  However, some test VIs I wrote seem to connect to only one multiplexer at a time.  Using a simple Windows test program, I have independently verified that both multiplexers are connected properly to the computer, and that I can connect to each individual one separately.  I have attached my test program, which attempts to connect to both instruments and then allow for inputs to each of them.  Am I coding this (in particular, the use of multiple ActiveX instances) properly?  If not, how should I go about opening multiple ActiveX instances in parallel?  Thank you for your help.

 

Note: this was written using Labview 2010.

0 Kudos
Message 1 of 4
(1,027 Views)

Most of us (like me) aren't going to have that ActiveX installed, so it's hard to say. Other than your inputs are named the same, I see nothing glaringly wrong. I would name the inputs differently - such as tack on the serial numbers.

 

Have you tried opening & setting up the two ActiveX sessions in series, then read in parallel?

Richard






0 Kudos
Message 2 of 4
(1,018 Views)

Which inputs are you referring to?  The serial numbers are specified in a "connect" function that occurs immediately after the automation open functions, so there shouldn't be a problem with that.  Opening the sessions in serial didn't help either.  I understand that most people won't have the specific ActiveX library; I just wanted to make sure I was following the correct procedure when I opened up parallel instances of ActiveX objects.  Thank you for the suggestions.

0 Kudos
Message 3 of 4
(1,012 Views)

Hello schr0dinger,

 

Typically, things will run in parallel in labview if you have independent while loops that have no explicit dependencies between one another. I would try modifying your vi to account for that and have the two activeX calls in seperate while loops and see if that helps out. The only caveat I would say is that you should verify that your ActiveX server that you are trying to access is thread safe otherwise you could run into some issues down the line. 

 

Best, 

Blayne Kettlewell 

0 Kudos
Message 4 of 4
(995 Views)