LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Packed library not loaded?

Hi,

 

I am working with a software architecture which makes use of packed libraries as plugins in a top-level vi. At each level in the hierarchy, plugins are used, so effectively each level is a project consisting of packed libraries loaded from the levels below.

I inherited this code from someone using LabView 2011, I am using LabView 2012.

 

My problem is that the project are failing to load the packed libraries beneath them. For exaample, my UI plugins don't load the packed libraries from the API plugins, which aren't loading packed libraries from the comms protocol plugins etc. ...


In the project explorer window, the libraries appear like: ProtocolPlugin.lvlibp (not loaded)
And I can't extract any information about why it wasn't loaded or what errors have occured.

I have tried going through each level from the bottom up, mass-compiling and rebuilding each project and packed library but the problem persists.

I have searched the web and the forums but couldn't find a similar problem to this. Has anyone experienced this and did you find a fix? 


0 Kudos
Message 1 of 13
(2,701 Views)

@DarraghCorrigan wrote:

Hi,

 

I am working with a software architecture which makes use of packed libraries as plugins in a top-level vi. [...]



How do you load the plugins?

Do you have a static call to it? Do you use "Get Exported File List.vi"?

 

Does your project show conflicts?

 

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 2 of 13
(2,698 Views)

Hi Norbert,

 

The plugins are loaded dynamically according to specifications in the .ini file in some projects, in others there is a static call, the problem isn't at run time though as this architecture has been used extensively before.

 

My problem is that when I open the project file and the project explorer windows opens, the .lvlibp files are not loaded, they appear in the list but are followed by "(not loaded)"

As a result, my vis in that project become broken, as the required vis from the library are not availble.

 

EDIT: There are no conflicts shown.

0 Kudos
Message 3 of 13
(2,690 Views)

@DarraghCorrigan wrote:

Hi Norbert,

 

[...]As a result, my vis in that project become broken, as the required vis from the library are not availble.


That sounds odd. If your VIs have static dependencies to the lvlibp, it has to be loaded automatically. If you have only dynamic dependencies, the calling VIs must not break during edit time.

Can you post an example showing this?

 

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 4 of 13
(2,681 Views)

Hi Norbert,

 

It's okay, I found a solution. I needed to manually remove the unloaded libraries and and then add the rebuilt ones. i think it's possible that the project may have been looking in the wrong directory, after the software package was moved to a new system.

 

Thank you for your help.

0 Kudos
Message 5 of 13
(2,671 Views)

Sorry for re-starting this old thread, but I just had a similar error.

 

The root cause was that the ppl linked into my project library was still for an old LabVIEW version. (in this case 2013 used in a 2015 project)

I really would've liked a reasonable error message whne loading the project..... but the Error Reporter Message when shutting down LV made me suspicious 😉

 

 

Join the Community!

GCentral
0 Kudos
Message 6 of 13
(2,511 Views)

I'm having the same problem.  2014 -> 2015.  What is a ppl? 

 

0 Kudos
Message 7 of 13
(2,445 Views)

@King_Cluster wrote:

What is a ppl? 


Packed Project Library


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 8 of 13
(2,443 Views)

OK, So I opened the project that contains the library and rebuilt it in the 2015 environment, but I still have the same problem.  Which is, if I create a new project in 2015 and add the rebuilt packet library I still get "(Not loaded)". 

 

Any thoughts on how to correct this?

0 Kudos
Message 9 of 13
(2,439 Views)

My guess is you have a conflict.  Is another copy of the PPL being attempted to be opened?  You could usually tell by looking at the Dependencies of a project.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 10 of 13
(2,434 Views)