LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

PXIe 8100 with R&S SMB100A driver

Hello all,

I have a PXIe 8100 with GPIB CARD and I'm trying to control via GPIB the signal generator SMB100A by Rhode&Swhartz using a program that runs on the RT module. I downloaded the driver for labview 8.2 (it should be the latest version available) and I tried to add into the RT target the VIs to communicate via GPIB with the instrument, but we I deploy the code, I get an error saying that the shared library rssmb_32.dll cannot be load into the target…does anyone have any suggestions on how to fix it?

 

thanks

0 Kudos
Message 1 of 5
(1,013 Views)

The driver most likely has a DLL, rssmb_32.dll, as part of its package.  That DLL will not automatically be deployed to the target with the VI, you'll need to find the DLL on your computer (probably resides in the same location as the VIs) and FTP that file to the /ni-rt/system directory on the PXIe-8100.  Assuming this is the only DLL the LabVIEW VI needs, this should solve your problem.

 

-Danny

0 Kudos
Message 2 of 5
(1,009 Views)

Hi Danny,

thanks for your quick reply...I thought I had to manually load that library on the RT target, but I did not know where exactly.

Now I transferred the rssmb_32.dll into the /ni-rt/system directory on the PXIe-8100, but I always get the same error:

 

LabVIEW:  Failed to load shared library rssmb_32.DLL:rssmb_error_message:C. Ensure that the library is present on the RT target. Use MAX to install NI software or FTP to transfer custom libraries to the RT target.

 

I actually checked if the library was present and it is!

 

...any other suggestions?

 

thanks a lot

 

eug

0 Kudos
Message 3 of 5
(991 Views)

You might want to see what is being displayed on the console of the controller.  When a DLL cannot be loaded, with LabVIEW RT 2010 and newer you get fairly good information on the screen about what the OS is trying to do.  It could be that the DLL is attempting to load, but cannot load for some reason - it could be that your driver was meant for Windows and not RT (and the .dll has things in it that aren't supported by RT so it is failing to load).  What is displayed on the console when you get this error from LabVIEW?

 

-Danny

Message 4 of 5
(987 Views)

...you are right...the dll file is not suitable for RT. I solve the problem by running the GPIB VIs on the host.

 

thanks for your help!

0 Kudos
Message 5 of 5
(976 Views)