From 12:00 AM CDT Sunday, October 17 - 11:30 AM CDT Sunday, October 17, ni.com will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Opining VI problem

Hi

 When I download any VI from internet and i want to open it from my PC whith labview 2013 i 'm always got these screen as attacvhed which repeated for many times and finally when the VI  opend it has no  compelte diagram inside

any advice please Capture.JPGCapture2.JPG

0 Kudos
Message 1 of 32
(2,012 Views)

Maybe you need to install some toolkits, e.g. LINX


LabVIEW Champion. It all comes together in GCentral GCentral
What does "Engineering Redefined" mean??
0 Kudos
Message 2 of 32
(1,996 Views)

What does you mean by "no complete diagram"?   Half of it is missing?  Or that there are subVI's it can't find and are replaced by ? marks.

 

It is looking for the file listed in the dialog box and can't find it.  Do youi have the \LabVIEW Hacker\LINX directory installed on your PC?  It is probably downloaded from the web.

0 Kudos
Message 3 of 32
(1,994 Views)

I mean by diagaram is some logic gates not wired or unknown function blocks

i already install the LINX firmware and its directory because i dont have any problem when I open labview linx examples.

any idea

0 Kudos
Message 4 of 32
(1,969 Views)

"LabVIEW Hacker" is a very odd sounding install directory.  So you may have installed them in a normal directory, but the original creator had their subVI's installed in the odd "LabVIEW Hacker" directory which doesn't exist on your machine, and your machine may not have the library in its search path.

 

Do you have the Digital Read.VI some within the path your LINX was installed to?  If so, when it gets done searching and can't find it, browse that file dialog box to the directory with the LVH-LINX.lvlib file in it.  Once it finds it and connects to it, everything should be fine.  Be sure to save that VI before closing so it remembers the location of the subVI in your new correct location.

0 Kudos
Message 5 of 32
(1,961 Views)

This happens only when I download vi from internet and save it into my pc on desktop or any place.

So please what shall i have to do to prevent this happned 

0 Kudos
Message 6 of 32
(1,946 Views)

There's nothing you can do.  Issue was caused by the person who created the original VI you downloaded.  They installed their libraries to a different place than you did.

 

Just make sure you installed the toolkit libraries to their standard install directory.

 

Once you fix the downloaded VI's, then be sure to save the updated version.

0 Kudos
Message 7 of 32
(1,939 Views)

Mustafasei wrote:  i already install the LINX firmware and its directory because i dont have any problem when I open labview linx examples.

How did you install LINX?  Did you use VIPM to install the package?  Or did you just copy the library to some arbitrary directory?

 

My guess is that you did the later, which means you are the odd one.  Install LINX properly with VIPM.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 8 of 32
(1,930 Views)

I install the linx by VIPM

0 Kudos
Message 9 of 32
(1,923 Views)

My guess is that whoever made the original VI being downloaded is the one who installed in the odd directory and did not use VIPM because the VI is looking for those VI's in "C:\LabVIEW Hacker" which is a very oddly named directory, plus the fact it is in the root drive, to have be the intended install directory.

0 Kudos
Message 10 of 32
(1,919 Views)