Showing results for 
Search instead for 
Did you mean: 

Ophir USBI .vis

I have a Ophir USBI interface, trying to use it with Labview so that I can create a program to take a 30 sec energy measurement every 10 minutes.  I can get it to link up with Starlab, can use the SwapINF utility.  Cannot get the interface to respond the Labview .vi's.  The initial won't even work properly.  I have tried all com ports on the computer nothing is working.  Anyone have any ideas or better directions then what Ophir Supplies?



0 Kudos
Message 1 of 8

Hi Dan,


Do you have a link to the software library for LabVIEW that we can check out? Is it available publicly?

Jeff | LabVIEW Software Engineer
0 Kudos
Message 2 of 8



The software is available here   If you download Starlab, the Labview .vi's are there; I have tried everything and as far as I am concerned its not the drivers for the USB interface, nor is it a connection problem with NI-Visa to the USB interface.  Its teh .inf files that they have to translate from the Ophir USB interface to NI-VISA protocals.  I have ripped apart their .inf files and I am able to get basic functions and see the device.  Cannot get the device to respond to Send - Recieve commands on measurements.  I have tried talking with Ophir service tech, filled out like 6 request forms to talk to their tech support, no response from them yet.  I figure I should be fine come Monday or so.  Thank you for looking into it.



0 Kudos
Message 3 of 8



My name is Scott and I'm looking into this while Jeff is out of the office.  I'm going through the files to see if I can come across a solution.  In the mean time, let me know if you ever get a hold of the tech support at Ophir and what they had to say.  Thanks,


-Scott Wiest

Applications Engineering

National Instruments
Applications Engineer
0 Kudos
Message 4 of 8

Hi Scott,


I am able to get it to work fully now, was acomplished this task by updating the firmware on the USBI device.  From what I can tell is that their .vi's are only good for the latest firmware of their interfaces, and for some reason the interface that I just bought less then a month ago didn't have a complete firmware file on it.  So now it works the correct way.  Sorry for the trouble.  I just think that Ophir doesn't pay attention nor fully tests the software with their products or this was just a compelte fluke.  My company has been having issues with Ophir products lately and their support so I don't know.


Thank you for looking into this for me,


0 Kudos
Message 5 of 8
I'm happy to hear that you found the solution, even though you had trouble getting there.  If National Instruments has a comparable device to your Ophir USB device I could get you a quote for it.  If you are interested, let me know the specs of the Ophir device and I will research to find a solution for you.  If you decide to stick with the Ophir device, as far as support goes, we will still be here to help you out if you need anything else.
National Instruments
Applications Engineer
0 Kudos
Message 6 of 8



The Ophir device is a USB interface that talks to Ophir's Pyro detector head, it comes with the detector and its own software, unfortunately I have to stick with the Ophir device.  I wish I could switch to a NI device for this project, never had any trouble with the NI devices or support.



Thank you for your support!!



0 Kudos
Message 7 of 8

The latest driver, Starlab version 2.20, is proving to be a bit flaky.

I can not get any support from Ophir. Very disappointing.

I, too, wish I had an NI product.

0 Kudos
Message 8 of 8