LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Open FPGA VI Reference on deployed VI (LabView RT)

I have a VI which opens a VI reference to an FPGA on LabView 2014 (PXIe-8135RT, Flex RIO 7966).

 

When I run the VI from the development host, it deploys automatically and runs without issue.

 

If I then deploy the VI via a source distribution, and invoke it using an invoke node or call by reference, this also works without issue.

 

So what's my problem?  When I reboot the PXI chassis, then try to run the VI by invoke or call by reference, the Open FPGA VI reference fails with error 1055:

 

Property Node in Test.vi->Test.vi.ProxyCaller

 

I have to run the test vi directly and let it automatically deploy first, before running it via invoke or call by reference will work.

 

vi.lib is included in the source deployment (Otherwise I get error 1003).  I have to manually FTP the source deployment to the PXI controller because selecting 'Deploy' on the source distribution fails (Only when vi.lib is included).

 

Any ideas what may be happening?

 

Thanks,

 

Robert

0 Kudos
Message 1 of 3
(1,597 Views)

Solved it.  This issue was caused by a property node external to the open FPGA VI reference.  The property node wasn't valid without the front panel (RT system).  These discussion boards need a way for the author to delete the original post 😉

0 Kudos
Message 2 of 3
(1,579 Views)

Don't delete it, other people may have the same issue. Just mark your second response as the solution.

0 Kudos
Message 3 of 3
(1,565 Views)