Showing results for 
Search instead for 
Did you mean: 

Odd delay on starting an exe using DAQmx

Go to solution
Accepted by topic author minnellac

We finally sorted this out. The full solution was to disable the .NET CLR Certificate checking and Enable "Turn Off Automatic Root Certificate Update" in Windows. This last step is done by: Run>gpedit.msc>Comptuer Configuration>Administrative Templates>System>Internet Communication Management>Internet Communication Settings>Turn Off Automatic Root Certicicate Update --> Enable. After applying this change, run "gpupdate /force" at the command prompt to force the settings to by applied (or restart I guess).


I tried this thing with the root certificates once before and it didn't seem to work, but I was mistaken disabling it. It is a double negative. It needs to be Enabled to turn it off (obviously!).


Anyway, to answer your questions, this is on LabVIEW 2011 32bit with DAQmx 9.3.5 on Windows 7 64bit & 32bit (32bit on the PXI chassis, 64bit on my test computer). That Hotfix looks promising, but the versions of those files on my computer are newer by 4 years, so I am not so keen on replacing any of them.


I would be interested to hear if this procedure fixes a similar problem for anyone else.


Thanks for your help!


Message 11 of 12

Just been tearing my hair out trying to fix this exact same problem myself, although in my case the executable seemed to run ok but would hang for a couple of minutes when any of the Labview built dll functions was called for the first time (then eventually execute correctly). Once one function in the dll had been called all subsequent calls to any of the dll functions executed quickly. This problem occured when I switched over to a Windows 7 embedded system from a Windows XPe system (where the problem didn't manifest itself).


Just to confirm the solution that worked for me:

1) Control panel->Internet options->Advanced

Under Security uncheck "Check for publisher's certificate revocation"

2) Start->Run->gpedit.msc

Computer Configuration->Administrative Templates->System->Internet Communication Management->Internet Communications Settings

Right click "Turn Off Automatic Root Certifcate Update" and select Edit

Select the Enabled radio button and click Ok.

Restart the PC.


Can't thank you enough for finding the solution to this!





0 Kudos
Message 12 of 12