Showing results for 
Search instead for 
Did you mean: 

Odd TC01 Thermocouple Data

I'm trying to use a USB-TC01 to gather some temperature data, obviously. I've used the Express VI and I still cant come up with relevant data. I've used the open front panel of the Express VI and saved it for your viewing pleasure. I'm using LabVIEW 2009 with DAXmx 9.1.


Please let me know what I'm doing wrong.

0 Kudos
Message 1 of 11

The TC01 has its own internal thermocouple so just plug it into your USB port and see what the pop-up display reports for that.  Also, check to be sure you have a K-type connected...

LabVIEW Pro Dev & Measurement Studio Pro (VS Pro) 2019
0 Kudos
Message 2 of 11

I'm using the internal sensor, so I dont have anything connected to it.


The software they provided works fine, however when I try to use their example the arrow is broken.

0 Kudos
Message 3 of 11

I just tried your VI with my USB-TC01 and it worked fine with internal sensor and external J-type TC.  If your arrow is broken, click on it and see what the error is.

LabVIEW Pro Dev & Measurement Studio Pro (VS Pro) 2019
Message 4 of 11

Ok, I'll chalk it up to not having the probe. The arrow comes from the supplied software trying to open the example in 2010 and my DAQmx drivers are located in my 2009 directory. I don't know what the problem is, but I guess we'll chalk it up to the probe and I'll won't worry about it until I have one.



0 Kudos
Message 5 of 11

If you've recently installed LV 2010, you have to install the DAQmx drivers after the LabVIEW 2010 installation in order for them to be installed in the LV 2010 environment.

0 Kudos
Message 6 of 11

Did that, they still installed in the '09 directory. Don't know why, don't know how, but it seems like I would be getting the same odd data in 2010 because I don't have the probe.

0 Kudos
Message 7 of 11

The very large value basically indicates a open circuit on the thermocouple channel.  By choosing ai0 as your channel, you are telling the DAQmx driver to read from the thermocouple channel, not the internal CJC channel.  The internal CJC channel is named "_cjtemp_.


To access this channel, right-click the Channel IO control and select "I/O Name Filtering"




Then check the box next to "Internal Channels"



At which point, you can choose the internal channel



It should be noted that when reading the CJC channel, information will be returned as a voltage and will have to be scaled.  This KB discusses how to do this: Why Does my USB-TC01 "_cjtemp" Channel Output a Non-sense Value?


The internal CJC channel isn't really meant to be used in place of a real thermocouple.  It is positioned such that it can account for errors due to the cold junction of the thermocouple plug and will always read noticeably hotter than the external thermocouple, because of its proximity to the on-board circuitry.


To use NI-DAQmx in LabVIEW 2010, you will need NI-DAQmx 9.1.5 or later.

Seth B.
Principal Test Engineer | National Instruments
Certified LabVIEW Architect
Certified TestStand Architect
Message 8 of 11

Perfect, thank you.

0 Kudos
Message 9 of 11

Thanks Seth,


I wanted to use the internal junction as an extra channel to record ambient temperature and forgot about the I/O filtering.  There should really be an option in the DAQmx channel pull-down selector that says (Show hidden choices...) as a reminder that a lot of stuff you can access is simply filtered from view.  I always forget about right-clicking the control to show everything and this would indicate that we're not seeing all the options that are physically available in our hardware.


A Kudos to you!

LabVIEW Pro Dev & Measurement Studio Pro (VS Pro) 2019
0 Kudos
Message 10 of 11