Showing results for 
Search instead for 
Did you mean: 

ODBC database renewed, Labview doesn't recognize it

Go to solution



For a long time ODBC access to a MySQL database worked fine with my LabView-VI. Recently I changed the database/catalog. (Not the ODBC-connection name.) The old one named 'mand15', the new one is now 'mand17'. The old one doesn't exists any more.


When I now try to access the database, LabView always tries to connect to the old one (mand15) instead of the new one (mand17). See the error message from LabView. This sounds resonable, but in my configuration, it was not necessary to point to a specific database I like to use. I cannot find a place where I ever entered the string "mand15". I only specified the ODBC-connection name. In my case "sage".

Where does LabView get the database name from?

Another question: Can I specify the database when I use the DB*.VIs?


Thank you for your attention and best wishes.




PS: I tried to run the VI on several machines and different LabView Version with no success.

Download All
0 Kudos
Message 1 of 4
Accepted by topic author Tukan_900

Hi Tukan,


If you are running a 32bit version of LabVIEW on a 64bit OS make sure you edit the ODBC entry for 32bit:


0 Kudos
Message 2 of 4

Thank you very much. I started odbccad32.exe and adapted the configuration. Now it works.


Best wishes. Tukan_900

0 Kudos
Message 3 of 4

Most likely you run LabVIEW 32-bit, right? And you started the ODBC Manager in the Windows menu and created a User DSN in there. And your Windows version is of course 64-bit.


The problem is that the ODBC Manager that you start from the Windows menu is for the OS bitness. And ODBC has seperate User DSN configurations for 32-bit and 64-bit. So you configured a new 64-bit DSN but the LabVIEW application is still using the old 32-bit DSN in your system.


Start up C:\Windows\SysWOW64\obcad32.exe and configure your "sage" DSN in there to use your new database schema and all will be well.

Rolf Kalbermatter
Averna BV
0 Kudos
Message 4 of 4