LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Not able to choose PXIe_clk100 on chassis devices

Hi,

 

I can't see the PXIe_clk100 in any of the devices on my PXIe-1095 chassis.  I have a timing module PXIe-6674T that I am able to sync to PXIe_clk100, but none of the other devices appear to share the 80ppb accuracy.  I attached a couple of pictures that show what I mean.  The one shows that advanced timing is greyed out if I try to create a task.  The other shows that PXIe_clk100 isn't an option if I try to use a property node like they do in this example. http://www.ni.com/product-documentation/11369/en/

 

This isn't specific to my DAQ card, I can't select PXIe_clk100 for my oscilloscope either.

 

Thanks.

0 Kudos
Message 1 of 5
(283 Views)

Hello,

 

For the first image you have given, can you open the tab for the module you are trying to use. From the picture I cannot tell if the PXIe_clk100 is available with the current image.

 

For your Task created in MAX, which module do you have set up? How do you have it configured?

Marina B.
Technical Support Engineer
National Instruments
www.ni.com/support
0 Kudos
Message 2 of 5
(239 Views)

Thanks for the response.  I'm out of the office today, but I'm having someone grab another screen shot.  I did expand that tab previously and it shows a 100MHz clock, but it wasn't PXIe_clk100.

 

For the second, it's the same PXIe-6363.  Not sure what you mean by how I have it set up.  It was arbitrary, but I think it was acquire signal, counter input, pulse width.  I've tied it with other ones, but you would think you could always use an external clock to acquire or generate signals.

 

 

0 Kudos
Message 3 of 5
(225 Views)

Okay, So I had a coworker expand the menu and and take some screen shots and they were there!  That annoyed me, so I ended up going into work to see if I was crazy.  I started a new project,  added an FPGA target, connected our PXIe-6674T from the "oscillator" to "PXI_clk10_in" and tried it again.... It wasn't there.

 

My end goal is to use the PXIe_clk100 on my FPGA.  I know there was a patch that went out a few months ago to fix an issue where the PXIe_clk100 wasn't able to be actually syncing to the device.  No one can remember if it got installed on the machine.  When I go through the installer, i get to a screen that says, "the following items will be installed", but there's nothing on the list and you can't click next.  Can't tell if it's already installed or if the installer doesn't work properly.

0 Kudos
Message 4 of 5
(219 Views)

Here is a possible solution, if you haven't tried it yet:

 

When you create a control or a constant, you can right click it, go to ''I/O name filtering" (see the picture), select all the choices to the right 'Allow undefined Names', 'Allow multiple names', 'Include Advanced Terminals'. Then the PXIe_CLK100 should appear if it is supported by your boards.

 

I know that the question was posted a long time ago, but it might be useful for other users.

0 Kudos
Message 5 of 5
(26 Views)