LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

No myRIO detected

Solved!
Go to solution

I have recently been trying to use a myRIO with my windows 10 PC for a university project. I have the student/home version of LabVIEW 2015, and the 2015 myRIO toolkit installed. In the devices and printers page, it comes up as "Generic USB-EEM Network Adapter" and in properties it says it is the NI myRIO. When I connect it to power and USB I am prompted with the menu shown in section 2 of this link (http://www.ni.com/product-documentation/14603/en/) but clicking on the Launch the getting started Wizard, it immediately prompts me with "No NI myRIOs were found". Any help??

0 Kudos
Message 1 of 9
(5,074 Views)

Sounds like you didn't install the cRIO drivers.  Did you install the RT module for when you want to develop in LV?

0 Kudos
Message 2 of 9
(4,983 Views)

I agree with the comment above, you can check this to make sure it is alright:

 

Required Software for NI myRIO
http://www.ni.com/product-documentation/14603/en/

 

Regards,

Daniel C.

0 Kudos
Message 3 of 9
(4,951 Views)

I installed the following links, and the same message still appears (see attachment).

http://www.ni.com/download/labview-real-time-module-2014/4846/en/

http://www.ni.com/download/labview-myrio-toolkit-2015/5548/en/

 

The myRIO still appears with the same name as it did before.

0 Kudos
Message 4 of 9
(4,939 Views)

Hi PGoodHand,

 

I have a few steps for you that may help you to discover the issue here:

 

  1. LabVIEW myRIO Software Bundle 2015: This linked download page will give you an installer that provides you with all the necessary software for your myRIO when using LabVIEW 2015. The Real-time module link that you posted in your last attachment isn't actually the correct installation (although I can completely understand the confusion based on the link).
  2. Ensure The Software Is Activated Via NI License Manager: Open NI License Manager (can be found by searching programs in your start menu's search bar). Then ensure there is a fully filled green box next to the Real-Time Module under the LabVIEW 2015 software. You should have been able to activate the required software by either a software serial number that came with your device or your university site license.
  3. Check NI MAX (Measurement & Automation Explorer): Open up NI MAX (can be found just as easily as NI License Manager from the start menu) and expand the Remote Systems section on the left panel. You should see your myRIO show up there. If it does, you can confirm it's status to make sure it is running correctly and there are no errors.

Lastly, if this still does not lead you to a solution, post a reply letting us know the following:

Alex W.
Applications Engineer
National Instruments
0 Kudos
Message 5 of 9
(4,929 Views)

I followed your steps. I'm not sure if I'm doing things the right way, my school has a license that seems to work because it allowed me to activate everything. There are two listings, however, one as Labview 2015 and one as Labview 2015 Sp1, shown in the attachments. 

 

When I connect the device and try the Getting started wizard, it does not recognize the myRIO and gives the same window as I got before.

 

It is infact a MYRIO-1900

 

It does show up under the Remote systems tab in NI MAX, however I do not have the correct login for the device and therefore cannot access any further administrative settings. The status says "Connected - Running"

 

It's operating system (copied from NI MAX) is: NI Real-Time Linux-ARMv7-A 3.2.35-rt52-1.0.0f1

 

I will contact my advisor about how to login to the myRIO, or at least get in touch with someone in his lab that has used it before.

 

Edit: I also tried all of the troubleshooting pointers on the link you provided, to no avail. I also tried to use it in Labview by creating a new Real-Time project and it shows up as a target, but says this:

"You have selected one or more systems that support LabVIEW FPGA programming mode only.  In order to program these devices, install LabVIEW FPGA."

 

I want to say it worked and allows me to use the device, only I have no idea if it is working or not and don't want to go plugging in sensors all willy-nilly. In the end, I wish to connect a load cell and do some field testing.

0 Kudos
Message 6 of 9
(4,912 Views)
Solution
Accepted by topic author PGoodhand

I figured it out!!

 

The software on my computer is Labview 2015, but the software on the myRIO was 2013 and this seems to be the disconnect. As it also turns out, the device is already setup so the getting started wizard will not be of any use to me, but still does not see the myRIO. I can now go to Labview 2015 Sp1 directly from the popup and can use the myRIO as a target and I have even done a simple "LEDs turn on when you push the button and go out when not pressed" program that runs just fine. Thank you all for your help!!

 

What I did:

1.) Go to NI MAX and find the device under "Remote Systems" and click the dropdown arrow to the left of the icon and name

2.) Right click on "Software" and click on "Add/Remove Software"

3.) I selected the Labview 2015 Sp1 option and then went through the installation process.

0 Kudos
Message 7 of 9
(4,904 Views)

my problem persist, I did all steps 

 

problema.png

 

 

0 Kudos
Message 8 of 9
(4,602 Views)

Hi Alisson,

 

Since this is already a resolved post, please create a new post for your question to make sure you get visibility on the forum.

 

Cheers,

Ryan

0 Kudos
Message 9 of 9
(4,544 Views)