Showing results for 
Search instead for 
Did you mean: 

Ni-DAQmx Driver support missing for LabVIEW 2019


We have LabVIEW v19.0 32-bit running on Windows 10 and one of our lead engineers is getting the attached error message:

"NI-DAQmx Driver support for LabVIEW 2019 is missing"

We've used the NI software to do a complete repair and reinstall all the modules but the error persists.

Running NI Package Manager 64-bit v20.1.0. 

When we click the link to download the v19.0 NI-DAQmx Driver, we get "No operation to be performed". 

What's the process to get this driver updated so we can run LabVIEW without errors? 


0 Kudos
Message 1 of 11

I would try updating to DAQmx 19.5 or 19.7.  You should have the option to install LabVIEW support.

There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
0 Kudos
Message 2 of 11

The Error Message suggests you might be missing a Driver, not DAQmx.  Why don't you attach the VI "Measure and record pressure"?  Please make sure to attach the actual VI -- a picture of it won't be as helpful in allowing us to "guess" what you might be missing ...


Bob Schor

0 Kudos
Message 3 of 11

We tried installing NI-DAQmx 19.5 and 19.6 and the installer posted the "No operation to be performed message" again.


Attaching a generic VI that produces the "NI-DAQmx Driver support for LabVIEW 2019 is missing" message. It's definitely a driver issue but can't seem to locate or install the correct one.

0 Kudos
Message 4 of 11

That VI really doesn't do much as it is a bunch of Express VI's thrown together.


I'm suspicious of the one called "Formula Node (Signal Express)".  When I tried to double click on that, I got an error dialog saying "Unable to View Properties".

Perhaps the missing support is related to something with Signal Express.  What happens when you try to double click on that Express VI?


Take a few steps back.  Can you create a small VI, even with just a DAQ Assistant and a graph and have it run and display data?

Can you take this VI, delete everything but the DAQ Assistant and a graph.  Will it work?

0 Kudos
Message 5 of 11

Truthfully, this post sounds exactly like what we're experiencing. I need to install support for LV2019, but the NI-DAQmx installer claims there's nothing left to add. Is there a way to uninstall NI-DAQmx on the machine and start over with v19.6 for example?


I also downloaded the NI Package Manager, and it responds back with "Package is already installed. No operation will be performed."


I looked at the NI-DAQmx driver files I downloaded, and it turns out I downloaded NI-DAQmx Runtime, which does not include the application support files.  I downloaded NI-DAQmx (only difference in the name was the lack of "Runtime") and repeated the installation.  There was now an option to install support for LV2018, and it was checked by default.  My program initializes without errors now.  I still don't know why the NI Package Manager won't install the support files with NI-DAQmx or list it as an option, but I have a solution now.  Thanks for the help.

0 Kudos
Message 6 of 11

Update: when logged in as the engineer we couldn't unload the 20.0 NI-DAQmx drivers without uninstalling LabVIEW for some reason.

I logged in as myself and was able to jettison 20.0. I then installed 19.6, rebooted, and got the same error message!


Missing NI Module, Toolkit, or Driver (1 warning)

Missing Components: 

NI-DAQmx Driver support for LabVIEW 2019 is missing


So we've tried 20.0 and 19.6, all of which are supported by LabVIEW 2019. What gives?


0 Kudos
Message 7 of 11

Sorry, I answered this in a reply to the message where you included your code, which led me to "the fix" -- you are missing NI's Signal Express, last released in 2015.  It might still work with LabVIEW 2019, is less likely to work with LabVIEW 2020.


Let us know if that fixes your "missing Driver" problem.


Bob Schor

0 Kudos
Message 8 of 11

Have you done the steps I said which was to just try a simple VI with  a DAQ Assistant?

0 Kudos
Message 9 of 11

Hi, I did find the download for NI's Signal Express, and on install it asks for a serial number or to run a 30 day eval. I chose the latter and error persists. 


I was considering installing everything from scratch but not sure if that would put us right back where we are.

0 Kudos
Message 10 of 11