LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

New Control Labels are bolded

I place a new control on a front panel and the label is bolded. It just started doing this so what did I do to cause this?

I have worked in Labview for years currently using Labview 7.0.
0 Kudos
Message 1 of 9
(2,375 Views)
some fonts are set depending on how they are in windows settings (assuming Windows OS).. Check on these settings
Also, in Labview menu, select
Tools
Options and then make sure the fonts are not set to bold. You may have pressed some keyboard key that automated that
0 Kudos
Message 2 of 9
(2,375 Views)
Already checked Options/Fonts and they are still default in Labview. Using Windows 2000 where would you think to could look? The label font is the standard Labview application font but is bold,
0 Kudos
Message 3 of 9
(2,375 Views)
Go to

Tools>>> Options >>> Font

Select application font.

click Font Style

Click panel default

ok

ok

drop a new control.


Ben
Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
Message 4 of 9
(2,375 Views)
Once you checked that the LabView fonts are set to "plain",
Tools>>>>Options>>>>Fonts>>Font Style
then the issue should be solved.

If not, go to windows settings>>>appearance
Then select the item# icon, menu, menu bar etc..
I am not sure which is the one to check,
but, for each item selected, check on the corresponding font that it is not set to Bold

Hope this helps

Imad
0 Kudos
Message 5 of 9
(2,375 Views)
Tools>>>Options>>>Fonts are all use defaults. Changed this for application font and it changed the VALUE part of the control but not the label. Changed it back no effect and it still bolds the labels

Appearance settings are the same as another windows 2000 system which does not bold label when controls are placed on front panel.

Any other ideas?
0 Kudos
Message 6 of 9
(2,375 Views)
It worked! Thanks for your help. Tried everything else in the Font options but this.
0 Kudos
Message 7 of 9
(2,375 Views)
> It worked! Thanks for your help. Tried everything else in the Font
> options but this.


I'm coming in on this late, but I'd guess that what was actually changed
was the Current Font definition. If you select something and change the
font, you apply it to the selection. If nothing in selected, you are
changing the font specification that will affect things that adapt the
current font, like free labels and the name labels of controls. So, if
you have nothing selected and you go to the menus and choose Bold,
subsequent free labels and name labels will drop bolded. Ditto for
making the font be Sand or some such. To put it back, have nothing
selected and choose App font or uncheck the other setting.

Greg McKaskle
Message 8 of 9
(2,375 Views)

This just happend to me - 8 years later!

 

LabVIEW 2012 running in Virtualbox.

 

The fix: Remove the "B" in the LabVIEW ini file entry: BDFont= "0" 15 B

 

Not sure how it got changed.

--------------------------------------------------------------------------------------------------------------------------
Help the forum when you get help. Click the "Solution?" icon on the reply that answers your
question. Give "Kudos" to replies that help.
--------------------------------------------------------------------------------------------------------------------------
0 Kudos
Message 9 of 9
(1,783 Views)