Showing results for 
Search instead for 
Did you mean: 

Network Shared Variables not recognized after re-opening the project

Go to solution

I've attached the project, it is not so big i think.


The problem comes from the variable stored in the VI "DisplayData" in the "Keithley237" class. 


Actually, i tried to create two new variables to replace the two ones failing, but any shared variables i put in this VI have problems when i restart. 

On the PC side i'm using them in the UpdateUIFromSharedVariables.



0 Kudos
Message 11 of 17

In order to prove this issue is specific to LabVIEW and not your project, I would just the bare essentials to replicate that the shared variables disappear when you restart your project. Sorry i wasn't clear enough in my previous message

0 Kudos
Message 12 of 17

I have this exact same issue. It first appeared today. I have LV 2015. I played around for quite awhile changing my file system between auto-populating and if it was because I was using a type-def. However, I don't know why but I created a new library and then I copied the code from the vi that can't keep the variable and created a new vi in the new folder and it works. It seems to me that something about a couple of my files is thinking that the network shared variables are not part of the project. I also found that when I had the variables in the "bad" file the new file and the old one had the error. But as soon as I deleted the variable from the "bad" file the new one is fine. ??? I don't know why it's so weird. I tried creating a simple test case but I couldn't get the same behavior.

0 Kudos
Message 13 of 17

I had this same problem last month with both LV2014 and LV2017.  Multiple shared variables in several .lvlib files showed that they were not in the project every time it was opened. When I tried to create a small sample to show the problem I discovered that when the containing folder was changed to Stop Auto-populating the problem immediately disappeared.

Michael Munroe, CLD, CTD, MCP
Automate 1M+ VI Search, Sort and Edit operations with Property Inspector 5.0, now with a new Interactive Window Manager!
Now supports full project automation using one-click custom macros or CLI.
0 Kudos
Message 14 of 17
Accepted by topic author SoheylV

I just found out that this is a known issue in Labview. Basically, there are issues if the file is auto-populating and also if it is used in a class. Turn off auto-populating for the folder that has the shared variable library and the problem should be fixed.


On a side note I also found out that there are issues with using Type-def for the shared variable in an executable. When building the executable check the "Disconnect type definitions" checkbox in the "Additional Exclusions" category.

Message 15 of 17

Indeed it solves my problem! Thanks a lot!


By curiosity, where did you find this information?

0 Kudos
Message 16 of 17

I had the same thing occur, but it appears that my shared variables broke after I had added them to a vi within a class and closed the project.  Once i removed the shared variables from the class vi (i had the project closed if that matters) and then re-opened the entire project all went back to normal.

0 Kudos
Message 17 of 17