LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Need help to communicate with newport optical power meter 1936-c in Labview

How do you address the instrument through raw USB?  What are the command sets or pipe calls?  Where are they described?  You help is greatly appreciated.

 

Thank you.

0 Kudos
Message 11 of 20
(1,546 Views)
Highlighted
For USB RAW, you need to get that information from the vendor. Each device's protocol is unique.
0 Kudos
Message 12 of 20
(1,538 Views)

Hi Agolovitser,

Just use the serial command-set found in the user-manual on Newport's web-site.

Here's a TEST VI in case it may help.

 

Cheers!

P.S. The top-level VI is named "Dvr.PM.Newport.2936-C(VISA)_Tools.TEST.vi" Smiley Wink

0 Kudos
Message 13 of 20
(1,517 Views)

Thank you for your help.

0 Kudos
Message 14 of 20
(1,505 Views)

I'm just checking to see if this issue got fixed.  I am using a Newport power meter and yes you have to install the interface software that comes with it to get the USB drivers installed for the device.

 

I attached the VI I put together to read from it.

0 Kudos
Message 15 of 20
(1,497 Views)

Hello all,

 

*Solved*

 

Solution:

Manually copy the following DLLs in the application directory:

1. powermetercommands.dll

2. powermeterlib.dll

3. usbdllwrap.dll

 

Findings:

During application build, the powermetercommands.dll is not identified as a dependency, so its not added to the project. This file is required by InitCmd vi. I didnt check to see if it'll work if DLLs are placed in "Data" support folder.

 

What didn't solve the issue:

* Installing the Newport software

 

What I didnt try:

* Raw USB communication - sounds tedious

Message 16 of 20
(649 Views)

Did you have to create a name for the USB channel in the NI-VISA driver wizard?   What is the Device Key in your jpg.?  Just can't seem to get the USB to work once it's created in the NI-VISA driver wizard....  Tried basic *IDN? query in the NI-VISA test panel...always get error.

Any help is appreciated.

0 Kudos
Message 17 of 20
(506 Views)

I assume that you installed the USB driver for the device.  Does the device come up on your device manager?  If not try re-installing the driver and point to the installation folder your driver is located in.

 

I'm not sure the solution for this will work if you haven't gotten past basic communications.  I would consider just using the RS-232 port or the GPIB port to talk with it.  You should be able to find the programming manual for commands.

 

0 Kudos
Message 18 of 20
(502 Views)

The device installs great and works with the Power Meter App that came with it.  It is visible in the Device manager.  But, Measurement & Automation doesn't see it unless I create the NI-VISA USB Driver... Once I create a NI-VISA USB driver it disappears from the USB controllers list in Device Manager and the Power Meter App no longer works. 

 

 When you say "re-install and point to the installation folder your driver is located in"  do you mean the NI-VISA driver?

0 Kudos
Message 19 of 20
(498 Views)

Reinstalling the driver won't help since it appears to be working correctly.  Just in case there was an issue I would remove the device in device manager and unplug it.  Then re-install the driver and plug it back in.

 

What version of the interface software did you install?  The one that I used before was ver. 3.0.2.  I was going to include it in this post but it was over the limit for posting.  If you need it let me know and I can email it to you.

 

That software will install the USB driver and it will also provide a folder that will give you plenty of LabVIEW examples you can try.  Have you tried those?  It should also give you an application where you can test simple communication to the instrument outside of LabVIEW to make sure it works.

0 Kudos
Message 20 of 20
(489 Views)