LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Need Help: Load cell stops reading after zeroing

Highlighted

Hey y'all.

 

Sorry in advance, I am very new to all of this, and I need some guidance. I've got a VI that I'm working with that I did not create, but have modified repeatedly, therefore I'm not very comfortable with what is going on. 

 

I'm running a script on a CRIO, reading data from a load cell, and have logic built in to zero out the load cell at the push of a button. This has worked for the last year or so, across multiple modifications. Now, when I zero out the load cell, it stops reading out data, and the display is grayed out. I have not changed anything since the last time it worked, it just started doing this randomly. Older versions of this same VI work fine, so the problem seems to be in this current change, but I have no idea why it would start doing this unprovoked. 

 

I've attached the VI, and 2 images, one showing the display before zeroing (working fine) and one showing the display after zeroing (grayed out, not working)

 

If anyone could point me in the right direction, or see anything wrong and help me out, I'd appreciate it.

 

Thanks

Download All
0 Kudos
Message 1 of 2
(163 Views)
Highlighted

The VI you attached doesn't show me anything that would explain this.

 

Perhaps the issue is in the Filter.vi subVI you didn't attach.

0 Kudos
Message 2 of 2
(136 Views)