LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NXG Waveform Graph Time Stamp to absolute time

Solved!
Go to solution

Don't know if i am not clicking the correct buttons or so but i don't seem to find a property to put the time stamp on the X axis on NXG. just for the sake of confirming that i am not doing anything wrong I tested it on  2017 and works.. on LV2017 I had to uncheck IGNORE TIMESTAMP... seems that the option is not available on NXG.

 

TimeStamp.png

CLAD, CTD
0 Kudos
Message 1 of 4
(2,917 Views)

Hi buton,

I tried recreating your NXG code, but I'm seeing the correct timestamp behavior. Can you share the *.gvi in question? I've attached the one which worked for me without issue. 

 

Additionally, are you in NXG 1.0 or 2.0?

Charlie J.
National Instruments
0 Kudos
Message 2 of 4
(2,876 Views)

Hi Charlie

 

I took your project and created another Vi. did the diagram and got the same results...

 

Find attached my Vi...

 

 

NXG 2.0 here...

CLAD, CTD
0 Kudos
Message 3 of 4
(2,868 Views)
Solution
Accepted by buton

Hi buton,

It looks like the issue is that your graph doesn't have the "Use waveform start time" option enabled, which can be accessed in the graph properties. You can either select the entire graph and use the Item properties in the right, or right-click on the graph and choose "Properties." Then you should see the following option if you scroll through the properties:graphOptions.png

 

 

Make sure you get the properties window for the graph and not just one of the scales.

Charlie J.
National Instruments
Message 4 of 4
(2,856 Views)