LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI usb 6008 data acquisition: a strange problem: mxwcgoutrunsilent.VI is Missed

Solved!
Go to solution
Highlighted

Dear NI 

 

Today I bought a  NI usb  6008 data acquisition

and i am using labview 2011
the problem is appear when after i end the configuring process of the I/o  data acquisition assistant

 the following picture shows the mxwcgoutrunsilent.VI is missed and a error happend

 

dataaqusition.jpg

 

can any one help to provide such VI for me

also what is the complete labview modules so can i able to make a real time data acquisition

 

best regards

hi ?Q>

0 Kudos
Message 1 of 8
(1,491 Views)
Highlighted
Solution
Accepted by topic author mangood

mangood, 

 

Do you received an error code? If so, what is it? What version of the NI-DAQmx driver do you have installed? It seems your driver potentially installed incorrectly, and you may need to reinstall the driver.

 

Here's the link to the latest version of NI-DAQmx: http://www.ni.com/download/ni-daqmx-9.8/4297/en/

Haley N
Applications Engineer
National Instruments
Message 2 of 8
(1,441 Views)
Highlighted

@hnesmith wrote:

mangood, 

 

Do you received an error code? If so, what is it? What version of the NI-DAQmx driver do you have installed? It seems your driver potentially installed incorrectly, and you may need to reinstall the driver.

 

Here's the link to the latest version of NI-DAQmx: http://www.ni.com/download/ni-daqmx-9.8/4297/en/


dear 

i downlaod the 9.5.5 but its still not work for LV 2011

but i test it with LV 2012 and its work

do i make the thread open or make it as solved

hi ?Q>

0 Kudos
Message 3 of 8
(1,432 Views)
Highlighted

Dear

I build this VI with lv 2012 to make an analog acquisition and the NI 6008 work very good with this VI

just an ask :: is the time delay block will control the sampling frequency ??? Also

is this VI complete or need other VIs to make the NI 6008 work all the time with out buffer or FiFo problems

 

ADC labview.jpg

hi ?Q>

0 Kudos
Message 4 of 8
(1,419 Views)
Highlighted
The time delay will NOT control your sampling frequency very well. You have hardware timed analog input and you should be configuring for that. Just look at the examples that come with LabVIEW.
Message 5 of 8
(1,409 Views)
Highlighted

@Dennis_Knutson wrote:
The time delay will NOT control your sampling frequency very well. You have hardware timed analog input and you should be configuring for that. Just look at the examples that come with LabVIEW.

i think today is not good for work

error massage when open any NI 6008 example

adc error.png

hi ?Q>

0 Kudos
Message 6 of 8
(1,401 Views)
Highlighted

Try re-installing DAQmx.  This time pay particular attention to the install support for page of the installer and ensure it is configured to install support for LabVIEW 2011 and LabVIEW 2012.

 

I suspect that LabVIEW 2011 was not installed before DAQmx or some component that NI Device Monitor supports was not encluded in the install resulting in the devmon configure this device wizard blowing up.

 

 

Alternately unplug the 6008, open DEVMON from the system tray and "Clear all device associations"  Plug the 6008 back in and when the devmon screen prompts you to do something choose "Do Nothing" and check "Allways do this"

 

EDIT:  I just read your latest post.  some install must have happened in the wrong order

 

Use the control panel add-remove programs to "repair"  LabVIEW 2011, LabVIEW 2012, and DAQmx then reboot

"Should be" isn't "Is" -Jay
0 Kudos
Message 7 of 8
(1,399 Views)
Highlighted

@JÞB wrote:

Try re-installing DAQmx.  This time pay particular attention to the install support for page of the installer and ensure it is configured to install support for LabVIEW 2011 and LabVIEW 2012.

 

I suspect that LabVIEW 2011 was not installed before DAQmx or some component that NI Device Monitor supports was not encluded in the install resulting in the devmon configure this device wizard blowing up.

 

 

Alternately unplug the 6008, open DEVMON from the system tray and "Clear all device associations"  Plug the 6008 back in and when the devmon screen prompts you to do something choose "Do Nothing" and check "Allways do this"


thank you 

 

hi ?Q>

0 Kudos
Message 8 of 8
(1,393 Views)