LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI-max sees like USB-6353 "USB\VID_3923

Hi. 

Before my device worked nice. One day NI max started to see it like in the attached picture bellow.

So, before it looked like "dev1" or "dev3"

Thanks!

0 Kudos
Message 1 of 7
(3,279 Views)

That's bad.  That means that MAX doesn't "see" the actual device, just that it is a serial device.  Have you been doing any updating?  Could you have a MAX Driver issue?

 

This happened to me a year or so ago.  It got "fixed" when I reinstalled/repaired LabVIEW.

 

Bob Schor

0 Kudos
Message 2 of 7
(3,217 Views)

Yesterday I was playing with it almost half of the day.

And I got solution. I deleted all software connected with national instruments.

Also I deleted in folders program files and program data national instruments folders. This could be done only in safe mode.

Then I installed DAQmx pack only. And it works. Hope It will help to safe time for other people.

0 Kudos
Message 3 of 7
(3,210 Views)

Had you followed my suggestion and done a "Repair" of all the NI Software, it would (a) probably have fixed it, (b) left you with LabVIEW installed and working, and (c) left your system in a "clean" state for future Software installations (if you, indeed, deleted the NI software instead of uninstalling it, you left a lot of "orphan entries" in the Registry).

 

Bob Schor

0 Kudos
Message 4 of 7
(3,197 Views)

I uninstalled software. But a lot of folders left after it. If I install again it without deleting folders, it will not work!

0 Kudos
Message 5 of 7
(3,193 Views)

In my earlier years with LabVIEW, particularly when I had more than a single version of LabVIEW installed on my PC and I "did something silly" in trying another install or upgrade or (worse!) removal, I would get to where you seemed to be, often after I, also, had removed Files and Folders manually.

 

I found a Sure Fire Fix that always worked for me.  However, you may be reluctant to take the first step ...

  1. Reformat the C: Drive.
  2. Reinstall Windows.
  3. Reinstall non-LabVIEW Software (Office, Acrobat Reader, etc.)
  4. When installing LabVIEW, follow these steps:
    1. Install only the version(s) you need.
    2. Install the oldest version first.
    3. If installing versions older than 3-4 years, install just LabVIEW, reboot, install Toolkits and Modules (the minumum subset you need), reboot, installed Devices and Drivers, reboot.
    4. Before installing the next version, open LabVIEW, be sure it is OK.  Open MAX, be sure it sees devices.
    5. With more recent versions, of LabVIEW, it is generally safe to install "all at once", but I still recommend installing Devices and Drivers separately, with an intervening reboot.

Bob Schor

0 Kudos
Message 6 of 7
(3,179 Views)

Thanks a lot for your support.

I am not using Labview. I am using Python as it's much more practical for me and free. 

But to initialize device I just need DAQmx install package and sometimes Visa.

For this reason I need NI-max to determine name of device for PyDAQmx library.

0 Kudos
Message 7 of 7
(3,177 Views)